Prime 4 player randomly stop/starting when playing

Has anyone had the issue in the attached video ? I am running 2.1.1. The right hand player stops and starts randomly, on its own. The same track will play fine on the left hand player This happens with any track in my library (internal 1TB SSD) It didn’t happen before I upgraded to 2.1.1

I have the same problem too. Also, the play button doesn’t work either. This only happens on the right deck. If I restart the console, everything goes back to working properly and no longer freezes. Then of course, let’s say after one day, it freezes again.

2 Likes

Same here ! I wrote a post and got no support solution. Each update brings more problems than fixes. I don’t understand why things are not tested before being given to customers. Don’t they have beta testing operations ? It seems that Denon is in a hurry to put new gears on the market, and it’s up to the customers to warn about bugs and find solutions by themselves. Really strange. If someone like @EthanLeo says that this bug DO EXIST, may be it will be taken in consideration by Denon.

3 Likes

I had that problem as well with a prime 2 in a bar. Try to disable vinyl mode, that should solve the problem. It’s better than restarting the unit during a performance.

That shouldn’t happen at all…

1 Like

Hi Guys, very sorry to see this. Under normal conditions that should not happen. I suspect something may be wrong with the hardware but a qualified technician should review the unit to confirm and repair.

Please connect with our support team and we’ll be happy to assist you with further.

https://www.denondj.com/support

I never use vinyl mode…

@DJMillbank @RapaNui If can help, now i am using a “Belkin Surge Stripe” and the problem seems gone away :slight_smile:

I’m having the same issue but… I downloaded the latest version, purchased the LC6000 connected them to my Prime 4 my issue is when I have all 4 decks running and the LC6000 on channel 4 for some reason puts the Prime 4 channel one into complete coma mode, no response, no movement even when I load a new track from the harddrive or from Tidal, nothing. I must admit I’m a huge supporter of the Denon Prime series and the Engine software which is taking the digital dj format to a whole other level. Standalone is waaay ahead and with WiFi leaves everyone in the dust. Just need to address several glitches so us Denon DJ’s can continue to play mix and create.

2 Likes

@EthanLeo Thank you for your answer. But the problem with me doesn’t seem to be related to overvoltage or erratic power, as I’ve seen this bug in several different places, clubs, restaurants, weddings, and always after first power up. Also, my Prime is most of the time protected by a UPS. I tried without, and it happens too. Thanks anyway. Other than that, I’m a fan of your YouTube videos. What you are doing is fantastic. Good continuation.

1 Like

@JWiLL

I have already gone that route and the reply I got was to contact Denon in the U.K. !

Not very helpful. Denon is Denon right, wherever you happen to be using your products ?

I don’t think this is a hardware issue, as it never used to happen, I also don’t think it’s a power issue for the same reasons.

Thankyou to the community for your replies so far.

Dear DJMillbank,

Since last September i had exactly the same issue with my Prime 4 on right deck The final solution was to go my prime for service in Athens Greece where i am located. As far as i know they fixed something internal with the grounds. No spare parts were needed. Until now works SUPER and i am happy again. So dont waste time and go for fixing it.

Chris

1 Like

Thanks Chris. I turned off Vinyl mode and that seems to have worked (as in a ‘workaround’).

Hello, Yes this works and I also did the same as i don’t scratch at all. But I I could not live with the idea that my controller has an issue so this is why I decided to fix it. If it’s OK for you then yes stay with vinyl off and you are OK.

1 Like

For me it doesn’t change anything. Vinyl mode on or off, after about 15 minutes, tracks on deck 2 are impossible to start/play.

If you have the same issue we are talking about, and if you immediately after power up you have vinyl to off you should not have the problem.

Can you try?

Already tried. It’s really a problem due to the v2.1 update because before when I was in 1.6, it never did. But even when downgrading, it seems that 2.1 leaves something in the CPU or somewhere else causing this problem. I redid the dowgrade in 1.6 about ten times but it’s over, the bug is now irreparable. And anyway, having the vinyl mode engaged or not should not logically break the playback of the tracks. Customers shouldn’t have to find cumbersome workarounds for update failures and errors

I’m seriously having this issue after updating the firmware to be able to use the LC6000’s for that true 4 deck mixing, but no luck and I’m a vinyl mode user, one of the reasons I have the Prime 2 and Prime 4, the Prime GO is my private dancer lol. Anyway even after disconnecting the LC6000’S from the Prime 4 my deck 1 will not respond to my touch of the jog. Frustration looms now for I have been promoting the Prime 4 as the end all for controllers. Any suggestions ?

If this was caused by firmware malfunction then they could fix it by a utility or something similar. If the jog wheel ring is not responding to the touch must go for service. At least this is what happened to me and believe me I tried a lot of things before I decide to go for service.

I insist on this as I spent hours and hours trying firmware downgrades and other stuff but finally it was an internal ground issue. After the repair almost 2 months now is perfect.

If turning off Vinyl mode works for me (and others), then I sincerely believe that it must be a firmware issue, especially since it’s only been since 2.1.1 (no issues before that upgrade).

@dj_chris I think that it could be fixed by a firmware upgrade (downgrade for the jog wheel components ??), as it was a firmware upgrade that introduced the issue in the first place !!!

What firmware are you presently using, have you downgraded back below 2.1.1 ?

@RapaNui

Agreed.

Spending a $H1T ton of money should NOT equal having to find workarounds !

We are not Beta testers, we have paid for the product and therefore, it should work, flawlessly.