X1850 LED Screen not working

Hi. Since updating the latest firmware the bottom LED screen is not visible. I’ve tried reinstalling etc but nothing seems to work

Have you tried to downgrade ? Or to download the update again?

Yes i have still the same

I have a similar issue but it affects both screens. After a few the screens go black. Going into settings brings them back again, but they shut down soon after.

Is there a screen time out phased in the new firmware? Didn’t have this issue before I updated…

There is a timeout, but you shouldn’t expect it to behave strangely after update. Can you find your way to the Factory Reset option on the configuration menu? Might be worth trying that to reset defaults, in case the upgrade didn’t succeed in doing this.

I’ll try that later today and report back if that resolved the issue.

Strange thing is that I was hearing a faint clicking noise coming from the mixer. Also smelled as if something electrical was burning.

UPDATE: I did a factory reset and downgraded the firmware back to 1.0.0. Screen still goes dark after a few minutes. Once you touch a control on the mixer, the screen comes back on. I wonder if upgrading the firmware enabled a timeout mode for the screen?