Problems with library & connecting SC5000 with serato

Hi, I contact you because I have few problems with my pair of Denon SC5000. I organise my library on rekordbox, analyse tracks, and export this in one usb key. Then When I put it into my denon sc 5000. it ask me to analyse tracks, I say yes. And then I see that half of the time the beat grid is wrong and the key is not analyzed.

Another problem is that since few times, when I want to eject my key. It saying " eject failed "

This is my configuration: PC with Windows 10 Xone DB4 Deck 1 usb out1 to Deck 2 usb 2 and connecting to pc / Xone Db4 directly connecting to pc / All firmware & Drivers update / DJ Club Kit for serato installed

Do you have any solutions? Thanks, Florian

Did you try using Engine Prime to analyse the files?

  • Plug that USB key into Engine Prime,
  • select all the tracks and
  • re-analyse.

When you say BPM is wrong what sort of values are you expecting and what are you getting.

What is the brand, size and format of USB drive are you using?

Cool

Hi mufasa, thanks for your help. I have imported my serato library to denon, and I already see that the beatgrid is not good. The beatgrid was well positioned, whether rekord or serato. I have already spent so much time on rekordbox for the beatgrid, & the cues… I don’t want to do the same with engine

The key is a classic sandisk 64go USB 3.0, format fat32

I forgot to tell you another important problem: my denon sc 5000 doesn’t recognize engine or serato when i’m trying to connecting to my laptop. it saying that’s looking for the computer… I also noticed that on some tracks there was a long silence of several minutes at the end of the track.

I’m pretty embarassed that it doesn’t work correctly ! (Sorry my english is not really good, I’m trying to do my best)

Don’t worry about this, you are doing fine!

Is the BPM correct?

When you import the tracks to Engine Prime from Serato, try REANALYSE the tracks.

Screenshot 2020-11-19 174400

You wont lose your Hot cues that were imported from Serato.

Re-analyse will not change your Serato & Rekordbox beatgrids and hotcues.

What mixer are you using to connect to serato?

yes the bpm is approximatly correct, but beatgrid is still wrong. to sum up, everything is okay on my laptop, until I export my library on a key and put it on sc5000. everything does not match

My question is that I want my key is programmed to have a rekordbox library export , because I could use it on cdj ( engine doesn’t work on cdj I guess)

Like I said I’m using a Xone DB4 The thing is that when I’m connecting my DB4 and opening Serato. It’s well detected, but as soon as I click anywhere on Serato, The click of the computer mouse is loading continuously and I’m forced to go to the task manager to remove the current software…

Approximately correct is not the same as Correct.

Can you share a photo of a track that has this issue on your 5000?

Try to connect one device at a time.

eg

only DB4 connected to serato dj.

what happens?

[]

Well, engine is okay for detecting bpm, but rekordbox has some difficulties, because often it gives somethings like 130.02 instead of 130.00 (compare to serato), but as the same time the beat grid is fine…

This is what I did, only connecting DB4 and I can’t do anything, I have tried all usb ports of my pc. also when I plug it, it say "hardware being connected, it may take a minute ", as if he reinstalled every time. Whereas before, when I plugged in a controller, it worked directly.

What do you think, should I uninstall everything ?

Engine Prime is more than okay. It’s quite accurate.

What is the artist and title of the track?

Different softwares have minor differences in how they register the bpm. Some store it as whole numbers others with decimals.

The beat grid looks fine to me. It’s landing on the beats for the snippet you uploaded.

With regards to the connection issue with DB4, check this out

Finally, the cable loosened slightly from my xone db4, so it could’nt connect. So everything is detected on my pc and working. However, I still have this problem of serato freezing. look photos:

from the moment I try to start reading on a song, it freezes… so I can’t do anything

Disconnect the prime

Using only the DB4 does serato work? You can play with serato and the db4 with Internal mode in serato.

Let’s start with that