Problem with Delete and Import Track to a Playlist

Hey Guys,

maybe I’m doing something wrong but let’s say you create a Playlist in Engine Prime Software 1.3.3 & 1.4 BETA…

  1. Drag and Drop a selected Track from your Collection to a Playlist you’ve created.
  2. Delete the Track in the Playlist (right click delete from playlist)
  3. Drag and Drop the the exact same Track in the same Playlist or any other Playlist again
  4. THERE IS MY PROBLEM…it’s not working

Any Track I deleted from a Playlist, can’t inserted to a new or even the same Playlist again???

Did I overlooked something?

I’m using Win 10 1909 64Bit

Thank you very much and all the best


Hi @Toby89

Sorry to hear about the difficulty - I’ll be happy to help!

I just tried to reproduce this in my environment but I didn’t encounter the same problem.

I was able to add > remove > add (same track) multiple times from both Engine Prime Collection and iTunes.

Where are you dragging the track from?

Does it happen with all playlist or just the one?

1 Like

Hi JWill

Thank your for answering

I’m dragging the Tracks from my Engine Prime Collection.

First of all I created some Crates…for Examples “Trance” or “Classics” then I create a Playlist. Now I’m dragging a Track from the Crate “Trance” to the Playlist. Everything works great so far.

But as soon as i delete 1 Track from the Playlist and try to drag it again in my playlist or any other playlist it’s not working anymore.

Every Track i delete from any Playlist can’t be added anymore to the same or any other Playlist. It’s not specific only 1 Track. Every Track from my Collection has this problem.

Only workaround so far is to delete my Tracks from the collection and import it completly new to Engine Prime


After deleting try the library optimization thingy, then add the track to the playlist again.

If it doesn’t help, this should be moved to the bugs section

1 Like

Optimization didn’t work but i checked every single folder related to Engine Prime. so after a few hours i think i solved the problem.

There was no “Engine Library” Folder on my system harddrive c:dokuments/musik

I copied the Engine Library Folder from my “Musik SSD” which is e: to the c: path and voila…it works

kinda strange but who cares. I’m happy now.

Thank you JWILL and mufasa for your friendly help

have a nice weekend guys and all the best

Toby :slight_smile:

1 Like

That’s strange

Usually when one installs engine prime that engine folder is created both on the internal and external drives containing music files

You may want to investigate further why yours did not.

I did a reinstall of Engine Prime whether a folder is created in the C: location and finally yes it is… Tried it 3-4 times. Everytime a folder. I don’t know what went wrong at first time. Maybe some mistakes from my position.

Most of the time the problem is in front of the screen :smiley:

Anyway it works and the topic can be closed because my problem is solved

Thank you


1 Like