Prime4 not working

Prime 4 won’t turn on it said preferals or something like that didn’t load on line update or ignore. I selected ignore whent on to menu selected track and it loaded but wouldn’t play everything just freezed so I turned it off and back on and it’s stuck on prime4 main screen with the jog centres going white and green

Have you tried holding down the EJECT button while powering on? It will force the unit into update mode and you should be able to see the Microchip icon on the screen. Then update once more. :slightly_smiling_face:

It’s come on it says the following peripherals did not come online during boot. prime4 mixer 01.21 options update fw or ignore. I’m currently on 1.32 and I’m not trying update or reboot I have just uploaded a album of itunes on to my usb and I think engine prime is playing up it says every track is 120bpm and won’t play nothing I wonder if it’s not loading on to usb properly and that’s what’s up. I seem to have all the music there then when I load a track it freezes

But maybe you should consider, running a update/ reinstall. Either to latest 1.4 or reinstall 1.32.

I’m not saying it will work, but I would try it.

@JWiLL - any thoughts?

Where version 1.4 is still in beta!

Hey Guys,

Its the same for me.

Updated 1.4 Beta but it doesn’t boot to start up the Prime 4.

Hello @Gareth, sorry to hear about your PRIME 4. First let me say, please do not try to update your console to the v1.4 beta as a means of troubleshooting. Instead, try to reinstall the v1.3.2 firmware. If this doesn’t work, we will work with you to rectify the situation.

@Gareth, Sorry to see you are having difficulty with your PRIME 4.

Do you see the same message every time you start the PRIME 4?

Could you tell me (or take photo) what the error message says?

If it’s saying that the one of the firmware components failed to load, you should choose “UPDATE” rather than ignore.

Having the same problem moxer 01.21 doesn’t load on boot and it seems like most of the prime 4 inputs from mixer do nothing and I can’t play anything I lod none of the keys seem to activate.

Hello @Gareth, are you still in need of support for your PRIME 4?

1 Like