Prime 4 Mic issues

Hi all,

I have an ongoing issue with microphones on my prime 4. They appear to be running way too hot, so basically when im at a gig, and lets say theyre being used for speeches, theyre fine (they sound fine, you can still tell theyre a little on the sensitive side but they work okay). When im playng background or low level music, again theyre okay. When ive got the volume up, say when the level display is pulsing into the first white LED, i can’t use the microphone properly because at that level it just distorts. So if i want to say something, or egg the crowd on, the mic is either too quiet or sounds terrible.

This is the case on both my radio mics and wired mic. Neither of these mics are particularly expensive or flashy, but theyve worked on everything else ive used.

The attenuation is turned all the way down in the menu. The best way for me to describe it is like the mic clips too early, i dont get the volume i need because the level just hits a ceiling. Ive tried mic up, master down, mic down master up, both up, it doesnt really make that much of a difference although i’d say its marginally better mic down, master up (that’s the way we like to… stop it.)

Theres other users i’ve seen, particularly on the facebook group who are having similar problems so i hope it can be sorted. I also don’t really suffer from rop outs, as per a lot of the previous mic threads i’ve read about on here so that must have been sorted.

Thanks

Gav

Does your mic have a gain pot or even a line/mic selector ?

Some of the microphones send out line level - they shouldn´t be used on prime. Some better microphones have a switch, to select between line level and mic level. If you have this switch … set it to mic.

I have no problems at all with my microphones.

I use: the t.bone TWS 16 HT (This is switchable and adjustable)

Thanks for replying DJDark.

No, my mics do not have a line/mic selector on them (unless its within the body and i need to take bits off to switch it. I will check when home).

Just off the top of your head, could you let me know what you’re set to? So: Attenuation Rough position of mic level Rough position of master Average output level on the LEDs (like green, touching the white, into the white, touching blue etc?)

Just helps me to see if my settings are good.

Cheers!

Talkover Level when used: -22dB Talkover Resume: Fast Mic1 Att.: -3db Mic2 Att.: -3dB

Mic1 Threshhold: -50dB Mic2 Threshhold: -50dB

Mic1 gain knob on prime a bit over half (53%) Mic2 gain knob prime 50%

Bass on 60% Mid: 45% High: 70% (on Mic1) Mix 2 has only low & high : it is on 56% high: 73%

The mics I use sounds normal on ever other system but a bit lifeless on prime … so the bass boost. but with this settings I am able to do a show as actor without problems.

by the way: microphone gain on the microphone receiver is set to 45%.

no distortion at all.

Master Level of Prime: 45% Gain Pot on every channel: 53% (They only left one white led off - never touch the blue)

Master VU: at -6dB - so you have enough headroom. you can allways then turn up master to around 60% without clipping.

Very important that your PA is set up nicely. I normally let my prime in this setting, and then turn up the PA volume to my desired system volume.

hope that helps.

(And when you can´t touch the PA because it´s in a club or hidden place - use the master to adjust the volume (just turn so that it sounds nice.))

Try attenuation all the way up ….

Attenuation means “to reduce” so the higher you set the attenuation number, the quieter the mics will be

Thanks,

Yes I know that but when the attenuation was up I couldn’t really even use the mic as it was so hot. I’ll look at getting a new mic and try and figure this out based on the above and your comment!

Thank for the help guys!

1 Like