Missing Artwork

Hi there, owner of an awesome shiny new Prime 2 for a month or so & new to the forum :slightly_smiling_face:

I am using DigitalDJ Pool (and others) for tracks and everything has been going well, adding the tracks to Engine Prime etc. Yesterday, I grabbed my first crates from DigitalDJ Pool and although most tracks have artwork in EP, some are not showing anything, which is a bit crap when we have jog wheels that show the artwork :face_with_raised_eyebrow:

I have done the usual stuff, deleted, re-imported, re-analysed, re-started EP etc and the artwork definitely shows in the folder on my Mac…just not for some tracks in EP.

Anyone seen this before and been able to fix it?

Cheers

try to reload the tags in EP.

additional questions

  • What software did you use to confirm the artwork is contained in the track’s tags?
  • What audio format are the tracks?
  • What is your collection manager/DJ Software other the Engine Prime?

@DJ_Nixr may need to archive the engine folder on his internal (and external) if re-import tags does not work.

It may be due to that issue when a track is already part of the collection and not being able to add new information.

1 Like

Cheers guys.

@MixMasterG_ATGR.nl - How do I reload the tags?

  • I haven’t used anything yet as this process has worked flawlessly so far
  • MP3
  • I only use MacOS and then drag into EP

right click the track from the collection view and select “Re-import track information”

as @mufasa outlined this may pose problems for tracks already part of the EP collection, see also this video: [BUG] Engine Prime 1.3.1 “Re-import track information” does not work

1 Like

Ah, ok thanks. Yes, I did that for all of the tracks already.

I’ll take a look at that vid tho, thanks.

EDIT - Yup, that looks like the issue.

I have downloaded the legacy version of PE, can I install and run that alongside the new version as per your video?

Cheers.

1 Like

That should be no problem. Since you are on MacOS there exist alternatives :wink:

1 Like
  • Downloaded PE 1.2.3
  • Renamed it to something else
  • Ran it and re-imported track information
  • All artwork now showing correctly
  • Opened latest version of EP - all artwork showing correctly

It’s clearly a bug, so hope they fix it in next version (v1.5?).

@MixMasterG_ATGR.nl - you sir, are a legend.

1 Like

I’ve tried to be as vocal about it as possible (look at the date on that video) but I usually get flamed for speaking this out loud, and mentioning there is an alternative that works :slight_smile:

so thanks @DJ_Nixr for the confimation

1 Like

They are aware

https://denondjforum.com/t/update-serato-performance-data-hot-cues-loops-on-subsequent-imports/20418?u=mufasa

I noticed same as well when adding extra stuff to serato library and it doesn’t translate to EP even after a Serato refresh

It’s a feature request that unfortunately isn’t getting any traction

The Serato cues/loops (and other EP build in conversions) and common tags reload bug are kind of related, because they both raise their ugly heads for tracks part of the existing EP collection.

The cues/loops updating behavior has always been a problem with every version of EP.

Prior to EP 1.3.2 reload tags was never an issue, regardless of tracks being part of the EP collection or not. Actually early versions of ■■■■ relied on reload tags for importing the common tags. Only when the bug struck I updated ■■■■ to convert all tags including artwork regardless of a track is in the EP collection or not.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.