MCX8000 Firmware Control MCU missing

I am trying to do a firmware update and the message I am getting is CONTROL MCU missing?

I have an issue similar to this where the update constantly freezes on “control mcu downloading”. I’ve tried multiple usb sticks even bought a brand new one. It’s frustrating as i can’t use engine prime and efforts to contact denon support seem to be getting ignored.

How have you done that? You should not be posting to social media for help.

i did it through the contact support page on the official website never received a reply.

That page also has telephone numbers for support, including Denon DJ Europe in Hampshire, UK.

Is this your way of helping with this? So you have an answer on how to resolve it?

1 Like

Have you gotten a resolution on this?

Assuming you’re replying to my post:

Strictly speaking, I shouldn’t even need to mention that there is telephone support, or where to go to get support, but it does seem that some people struggle with it. :man_shrugging:

Hi. Im having exactly the same issue. Been in touch with Denon & Thomann. Mine was brand new out the box, half an hour in i tried to update and just get to the same stage as you. Im fuming as the supplier are delaying things, and am almost ready to send it back. Have u got any progress with this issue mate? Ive tried multiple usbs all using FAT32 and 2 diff computers. Nothing is working.

Just edit your last post - rather than writing two posts next to each other