MC6000MK2 as external mixer in traktor

Hi Everyone!

I’m starting playing, i don’t know much about mixers and their configurations, and I have some doubts.

I bought a mc6000 mk2, and I’m trying to use as external mixer in traktor, but with no sucess. It only works as internal mixer, asio drivers and 2 decks. When I change to external mixer and select the “mc6000mk2” device (not the asio one), the sounds get a better quality, all 4 decks appears in traktor properties, but the levels and crossfaders stop working. Does this controllers really works as standalone mixer? I’m using the RCA cable, not the XLR balanced. Does it affect the behavior of levels and crossfader?

Thanks!

The MC6000 Mk2 does not support external mode. It has to be used in master + headphone software mode only.

This was removed when it was watered down for Serato along with the booth EQ in the Mk1

Thanks for the fast reply!

Is it a traktor compatibility problem? Will it work as external mixer in Serato?

No, it’s the actual type of sound card used in the controller.

Doesn’t work in external mode with any software.

When the Mk2 came out it was at a lower price point and this was one of the cost cutting changes.

Yes it does. But “standalone mixer” does not mean external mixing of software decks. It just means it can mix external sources (line/phono) without the laptop.

Actually, this has nothing to do with the type of sound card used in the controller but the way audio is being routed by the controller.

As kradcliffe said, it’s not something that can be changed by using another software. MC6000mk1 has a switch on the back of the unit labeled “PC Mix/INT Mix” that determines how the audio/midi path inside the controller is routed. When INT Mix is selected, the mixer section of the unit stops sending/receiving midi messages to the software (so it cannot mess with the internal software mixer and lights on the units mixer section) and audio from usb soundcard’s outputs is routed through the mixer section (instead of the outputs+headphone) so hardware eq, cue and faders can be applied. So, on the one hand you get lower amount of midi messages sent/received (you can get lower latency in software?) but you loose the ability to select how your EQ will be (full kill or -26db and crossover points - Traktor has many options for example) and, probably the thing that most people cared about - you loose the ability to have post-fader software FX (no echo tails when you lower the linefader).

The only two controllers that can work like that are MC6000mk1 and DDJ-SZ (and the SZ cannot change that - that’s why you will see countless posts on Serato/Pioneer forums from people complaing about why their flagship controller cannot have software echo trails - and that’s why they have released SZ2 version).

And most important thing: if shouldn’t affect sound quality. Make sure you have Traktor settings right (EQ mode for example).

Thank you very much cradcliffe and SlayForMoney for all the explanation!! Now I understand a little bit more how does it works.

I’m glad to know that there’s no loss of sound quality. I’ve checked some settings in my traktor, auto gain and limiter are enabled, and the headroom is at -6db. I think they’re all “turned off” when I choose external mixer, and that was the difference I’ve felt. Any suggest of good settings will be appreciated =]

Now I just need to adjust the mapping to use 4 decks, because the official’s one is not good (knobs of decks 1 and 4 are useless in this mapping). If I can get it, I’ll post the mapping.

Once again, I appreciate the support!

Yes, limiter is the most likely problem. Auto gain is ok, leave it on. If your tracks (with the auto gain on) hit the red on the Traktor meters try setting headroom to a -9db value or lowering master volume knob in traktor to -10db. Gain staging is a tricky bussines, if you lower your headroom or main volume too much you might get too quiet headphones or master output when connected into a club mixer.

Some useful links:

Great! I’ll read these articles and make some tests.

It’s been ok with headroom at -6db. Never get the red. I’ll try to disable the limiter, and other stuffs.

I rarely touch in the gain knob. I’ll give it more attention. The problem is that I often play at headphones, and I don’t fell too much difference between the musics. But I know that in large speakers the gain difference between the tracks is more audible.

Thank you so much Slay!!! It helped me a lot!