MC6000 & Turntable & VDJ 8


I’m hoping someone could help. Im using the MK6000 mk1 with a turntable & VDJ 8. However whatever im scratching with the turntable the only place I can hear anything (from the turntable) is though the headphones. Which are connected to the controller directly. But the controller is not passing the turntable sound to the PC. Therefore VDJ is not getting any sound from the turntable. VDJ is getting the sound (as expected) form mp3s etc.

Is there a setting on the controller that perhaps im missing? or is my expectation too high that the controller will pass the sound from the turntable to VDJ? Therefore not convert the analog signal (RCA) to digital though to the computer via USB.

Tried both Line 1 & 2 on the controller, and using the line and phono options.

BTW using Windows 8.1

Thanks in advance.


Thanks for posting.

Can you please provide me with your full system specs? Please also confirm that you’ve installed the Windows driver for your MC6000. This will ensure that your controller is properly communicating and operating as it should with your computer - MC6000 Windows Driver

Also, only in the latest firmware version MC6000mk1 has enabled DVS function.

Ok I’ll check that when I get home tonight and report back.

However for sake of clarification, I am not using timecode vinyl/DVS or anything like Serato scratch. But instead using actual vinyl for scratching. (Not sure if it makes a difference to the awsners above).

I can confirm that I have in fact the new drivers.

For system specs, because I am a new user on here I cant upload images. However I did take screenshots of VDJ settings, and other aspects of my system. Please use the link below to get the details.

Ive tried all the output options and subsequent combinations on my system that I can think of. The only way sound gets passed to the computer is when I use the output “Realtek High Definition Audio” in VDJ. Again its only the digital files, not the turntable.

Also I can confirm that on the controller the deck has selected “line 2” on the one channel the turntable is meant to be on.

Any suggestions? What am I missing?