Ibrate the jog wheels?

Is there a way to calibrate the jog wheels. The jogs on both players starting becoming so sensitive that touching the outside anywhere near the platter engaged jog touch (stopped the music playback). This occurred while the units were in use last night. All four DJ’s (including myself) experienced this.

Check the grounding of the power they’re connected to with a tester.

If that checks out, it could be static electricity your body is building up, in which case you need to ground yourself to something metal on the unit from time to time, like a USB socket or the ground screw on the back to discharge the static charge from your body.

Touch platters that are metal, by the way, do not develop this issue, but some of them are also manually-adjustable in the sensitivity. It looks like what they’ve said on the forum before is that the non-Ms auto calibrate when turning on. They might want to consider allowing a manual adjustment for it, too, but I’m not entirely certain how it works.

I have previously suggested they change the behavior of the ring LED to make it easier to spot when something is malfunctioning with it, as when you do have static electricity or ground problems it can flicker so rapidly as to be impossible to see right now.

https://denondjforum.com/t/change-in-scratch-led-ring-function-recommended-on-touch-version-of-sc5000/

They were properly grounded and four separate people experienced the same issue.

Did you use a tester to check the socket? At a venue on June 8th one power strip was not grounded and I had to put the units directly into a Furman that was. The power strip showed an intermittent ground on the tester. I had no issues the whole night.

If you did use a tester and it came back truly properly-grounded, next time it happens try having everyone ground themselves to something metal on the unit briefly and see if that clears it up… or you can all hold hands and one person touches it :stuck_out_tongue:

I’ve had instances of the touch on them going nuts on me and it took a while to even figure out it wasn’t an audio problem but the touch. Early on I was not using a tester to check sockets first and since doing that now the only time I’ve yet experienced it is with static electricity from being on carpet and rubbing socks accidentally on it, usually when it’s cold & dry out. Touching the ground screw or the USB socket fixes that now, though, but it’s certainly possible some of my early problems (and yours now) is caused by something else going on… like it’s losing its calibration or needs to be auto recalibrated again after a few hours or manually adjusted.

It’ll be a venue issue - sloppy grounding / earthing or a worn power cable or faulty equipment elsewhere on the mains allowing some live or neutral to taint the earth cables.

Have you tried the decks / mixer today at home to see if issue remains - if iissue not there now at home - it was the venues issue.

It was at the Mad Frog, so yeah. Used my multi meter before plugging in.

Issue remained when I plugged em in at home. Never had the issue at home before. Also no ground issues at home.

I’m not sure how you use a multimeter to test for ground. You have instructions for others for that? I just use one of these…

image

As for what’s going on in your case, I at one time had a sneaking suspicion some electrical contact between the jog and the rest of the unit, maybe part of the spindle system, might occasionally become intermittent or break continuity, causing the touch calibration to reset. But that was just a theory I was going on months ago prior to me thinking I’d resolved it by narrowing it down to a combination of bad grounds and/or body static electricity.

Same way you check the ground of any system with a Multi Meter. In this case, you do so while setting to VAC first. Ensure your voltage reading is steady on Feed and Ground. Then move ground to earth ground and ensure voltage does not fluctuate and remains steady. If there are jumps or any discrepencies between the two, then the outlet is not properly grounded.

1 Like

Interestingly, nothing on the jogs is conductive. That’s suprising. There’s a guy with an incompletely-built Prime 4 that arrived to him on FB and there’s this metal-like laminate peeling back. For a brief moment I started to have hope maybe the grounding issues with static electricity and touch were totally (and easily) resolvable if that’s indeed a layer of metal on all these Prime touch platters. I previously thought the whole jog top was one piece of tempered glass, but it’s not. However, that thin, flat ring surrounding the jog display is not metal, either. Not even the outer jog is conductive. Oh well.

So I guess we’re back to wondering why the (must be) proximity touch callibration is going haywire.

Maybe we can get some clarification from Denon on which touch technology is used on these units. I for one, am not about to take one of mine apart to find out.

After playing around at home, one went back to normal after the second restart. The other went back to normal after 4 restarts.

Well if nothing is conductive on the top still (even after it appearing to look metal), then it must be some form of proximity touch, like the tempered glass of a smartphone, right?

That still leaves two options, resistive touch or capacitive touch. I have attempted touching the jog wheels with non conductive materials.

Isn’t resistive squishy? And if it was that, proximity and static electricity wouldn’t trigger it. Metal capacitive touch like on Hanpins never lose calibration and never are adversely affected by static electricity.

It’s not resistive - this would act more like mechanical jogs and require actual downward force to be exerted for a touch to be recognised.

They are capacitive. Put a glove and try to recreate the problem.

If i touch any case screw on the player it will work . Touching my mixers metal case also nullifies the issue. Everything is grounded … I’m an electrician and installed proper grounding… rods… water pipe bonding.

I have a feeling humidity has something to do with the capacitive circuit reacting badly

Probably. Gemini had to do something with the auto calibration on theirs due to humidity reasons. I think part of it was basically erroring on the side of less sensitivity. I don’t see why we can’t just manually adjust it like on Hanpins, though.

1 Like