Help: SC6000M stuck in a Restart Loop, Unit seems bricked

Hello,

We have an issue here where one of the SC6000Ms is stuck in a Restart Loop where it says: “Updating SC6000M Motor to 04.04”

Issue began:

  1. While playing, the motor suddenly stopped moving, and became unresponsive. Cannot play tracks. Screen was still working (Video 1)
  2. Ejected Harddisk no problem
  3. Powered off the unit and then powered on
  4. Unit became stuck in a Restart Loop (Video 2)

Solutions tried:

  1. Holding the power button to get the unit to restart
  2. Force update the unit via Mac (Video 3)

Please help. It’s a month old unit.

Files attached:

A few people have had this problem. One way is to hold the power and eject button. I would jump in those posts and talk with the people who fixed the problem.

Holding EJECT and Powering ON does nothing on an SC device. He is doing it right.

@thelittlemidistore, could you try updating with a USB flash drive or SD card and see if it then walks through the motor firmware step.

Have tried with a USB Drive, not tried with an SD card, will try that out

Thank you

Okay. I’ve tagged staff, but perhaps contact your reseller as well in the meantime.

1 Like

Hi, any help from Staff? its been 29 days today

Here’s that black hole I’ve talked about once today already. Denon make great hardware, probsbly the best hardware DJs but they’ve seemed to have only half the support staff that they should have. Like a beautiful bird of prey who lays valuable eggs then walks off and leaves it defenceless on its own

Agree on the point about better follow up from Denon staff. There was another thread on here regarding jog issues were a lot of people commented yet very little response from Denon staff. And referring people back to the seller isn’t much of a solution when replacements aren’t readily available. The approach to support seems to have been a little underwhelming with the SC6000.