Hardware or Software problem?

When playing track of music, if I touch the RH platter and slowly, or fast, wind backwards, the track stops playing and I can’t restart it. I can hold the cue button down and it will play, but not with the play button. The controller is sending a signal, but the software is not acting on it. Any ideas guys?

Hi @Kevmia and welcome to the forum!

I’m sorry you are having this problem, it sounds like the best option here is to contact customer support direct to assist: https://www.denondj.com/support

Regards J

Thanks Jay.

I was just wondering if any body else had the same issue at some point.

Thanks again.

Sounds more like a software issue to me. Are you using Serato ?. If so i have found V2.0.5 to be the best / most stable version.

Hi Paul,

Rolled back to 2.0.5, no change. Further investigation, it now appears that his happens as soon as I touch the platter, I don’t have to move it, it just pauses the track and thats it. The left channel is worming fine.

I had the EXACT same problem. Had to improvise last Friday night right in the middle of a set. I couldn’t restart, dance floor was packed and never hit a dead spot, luckily my left platter stayed up and I could drop tracks on deck 4 using hot cues.

If you ever figure out what causes this keep me posted, I just bought the prime 4 but will still be using the 7000 from time to time.

i had the same issue last night

after coming from the mcx8000 i have been so happy with the mc7000, been reliable did a gig last weekend and been working on and off last few months no issues,

last night all of a sudden platter one lost its sensitivity and couldnt hold the track like on vinyl and then plater 2/4 woudl press play button and software say it being pressed but nothing happened.

we tried two laptop and three cables all same results and even did hardware reset and no difference

luck for me this was just around the corner from my house I run home got my decks and rane 64 and for first time in three years did a gig on vinyl

I’m going to jump in here and say I’ve had the same problem happen a few times. The first time it happened my platter sensitivity wasn’t set correct and presumed this was the source of the problem, but after adjusting it I next did a big 6 hr gig and found the platter on the left just scrubbed through he track VERY slowly (so was practically useless), and the music could be started with the cue button, but not with the play button. I muddled though the gig using the second layer which appeared to work generally fine with the platter, but had the same issue with the play/cue button- but I could just press the play button on the laptop to start the track- not ideal but a workaround nonetheless.

I only use the controller a few times a year for gigs where speed/portabiliy is a priority, otherwise I use my sc5000’s/x1800 but it does make me nervous now to use it in a professional setting (and is now out of warranty, even though it’s only been used about 7 times in total)

Put your controller in settings mode, do a factory reset then increase the platter sensitivity, I set both of mine to maximum. I had that exact problem, if you turn the vinyl setting off it will actually start running again but you won’t be able to pull back. I haven’t had that problem since doing this a couple days ago.