Engine software issue

I am noticing issues with engine (mac) not transfering my edits to my prime 4, via usb

here is what is happening: i went to make a new playlist under my usb as i always do using engine (mac). after plugging my usb into my prime 4, the usb loads fine (as I can select and load playlist) but under my playlist via usb on the unit (as i have always done this with no issues), the edits i made on the usb using engine(mac) do no show when plugged into my prime 4.

the prime 4 is missing playlist compared to the engine software and vice versa. Engine shows how i want things, but the prime 4 decides to show what it wants, whether its playlist ive deleted on engine or playlist that don’t even show up on engine but do on the unit. there is some major software issues and things not communicating as they should. last time i made edits on my usb was about a month ago and it worked perfectly fine, so i am assuming this is something that has ocurred during an update or “migrating” the usb to the prime 4, which i have never sen previously until the latest update. will migrating effect this?

yes, both the prime 4 and engine are up to date.

yes, i tried several usb and ssd’s and still the issue persist- i have also tried erasing a usb and starting over and this issue persist.

i have tried making edits under the usb on the unit and they edits do not show up under engine and vice versa.

yes, usb’s etc have been ejected properly and working perfect

update: i put the usb back into my mac (i have this backed up on another usb just in case), i dragged and dropped files from my engine playlist (usb), to a folder on my mac desktop. closed engine and erased the whole usb and started from scratch.

plugged the usb back into engine(mac). created a new playlist under the fresh usb, then dragged all the files from the desktop to the playlist under the usb while using engine (same as ive always done). ejected usb

plugged usb into prime 4 and migrated (library needs an update- which is weird because both engine and prime are up to date)

loaded tracks just fine but had to redo all hot cues (SMH obviously)

this took a little bit with only 40 tracks i tried, but this worked. the issue is now, how do i do this in a timely manner saving my hot cues with thousands of files now lol

update number 2:

I put in the usb and the old usb together on engine. i thought i could drag and drop playlist via engine to save some time from the old usb to the new usb to keep my hot cues. this worked on engine prime as it should and i could see it right under the brand new playlist i just made on the new usb. there are now to playlist created. one of the 40 tracks i dragged and dropped from my desktop and 1 of the old playlist dragged from the usb via engine. after ejecting the usb and plugging it into the prime 4, only one playlist shows and its the first one i created with the 40 tracks. the second playlist dragged from the old usb via engine does not show up on the prime 4 but does on engine.

corrupt files?

update number 3 (all done under engine)

with both usb’s plugged into engine, i created a new playlist under the new usb as i did with the first playlist of the 40 tracks

went to the old usb and copied tracks from a known playlist that shows under both engine and the unit that is known to be visible on both platforms. (on engine, playlist via old usb, command a, drag files to playlist to new usb)

worked perfect under engine. ejected usb. usb into prime 4. only one playlist shows. the new playlist created does not show. whether i create a playlist and drag tracks to it or drag playlist from usb to usb, everything shows on engine, just not prime unit.

seems to be a writing issue or corrupt issue with engine to prime and not allowing the prime to see the new files/ playlist

ive also noticed that after messing around, the prime unit does not auto save “history” anymore you can see on the usb while under prime. ive mixed tracks a few times enough to have at least two history sessions and those are not visible under prime unit or engine…

hmmmmm…

Look : https://denondjforum.com/t/engine-library-on-external-ssd-only/38244/9

tried this, does not work.

Do you add music files to Engine Collection (Mac) in the first instance?

Where is the core collection?

i have never kept a core. ive always created playlist under the usb via engine and set hot cues, analyze etc on the usb. i keep all my files off my mac so keep it running faster…

ive never had issues with this, have ran into this issue or had problems with creating playlist under the usb via engine until this update in the last month

  1. by design there has to be a core collection (then again you stated that it was working fine prior)

  2. that core collection does not have to be internal to your mac

  3. is all your music on the USB?

  4. do you mind sharing (step by step) your workflow starting from downloading music…if you can

gotcha, yeah then everything is on an external ssd. so there should be no issue there. posting another update soon. think i found the issue to denon to look into to.

update number 4:

after the previous steps did not work, i thought the issue might be with migrating and i believe i pinpointed this now.

  • i erased the new usb once more with it being now completely empty and nothing on it.
  • plugged the usb into engine along with the old usb.
  • no playlist were created on the new usb
  • dragged and dropped a minimum of 10 created playlist from the old usb to the new usb via engine.
  • took a little bit but done and hot cues saved. everything looked great on engine.
  • ejected usbs.
  • plugged new usb into prime unit. wants to “migrate library or eject”
  • migrated library
  • after complete, checked all playlist and boom, all playlist are visible, hot cues etc
  • ejected usb, added a new playlist once more … finish with same steps as before.
  • plug usb into prime unit. ni migrate option requested.
  • checked playlist, no new playlist but all previous 10 playlist are.

long story short. once you migrate library on usb, it some how corrupts files and or usb to not make any changes and show them on the unit. BUT you can see such changes under engine. not sure the fix for this but engine library is up to date everywhere.

it should not be asking to migrate playlist if the playlist was created in engine dj (mac) 2.x version

you may have a corrupt library database (on the mac)

i was just thinking that. i tried removing all engine files and uninstalling, redownloaded as one of my first steps and the issue was still there. how do i go about wiping engine completely and all of it entities to reinstall a fresh updated copy?

  1. exit engine dj (mac)

  2. go to music folder, you will find a folder called “ENGINE LIBRARY”, rename it to “engine library OLD”

  3. If you store music files (source) on any external drive (collection drives), go to the root directory of the drives and rename all the ENGINE LIBARY folders.

  4. Download the latest Engine DJ for MacOS and install. Start up Engine DJ Mac…the library will be empty.

1 Like

(smacks forehead)