Engine prime swapping track metadata

I updated EP a few days ago. Immediately noticed quite an annoying problem that has not occurred with older versions.

When copying playlists to an external drive, the metadata gets copied correctly, but the actual data (i.e. the track file) doesn’t. Which means I end up with a correct ‘playlist’ but once I load the track on the player, a different track comes! It’s so weird. The waveform, title, album etc all are correct, but the file associated with it is a different file, a different track.

This happens in about 10% of cases (4/30 tracks in the smaller playlist), which is really high, and because all the metadata are correct, the only way of verifying whether what I put on my usb stick is correct is to manually go through all the tracks (I have 228 tracks in my longer playlist…). If they are incorrect I have to delete their counterpart (i.e. the track that I actually hear) from the Library, and then re-copy to the thumb drive.

Just imagine going to a gig to discover 1/10th of your tracks is not what you copied. It’s ridiculous.

Also, I don’t want to rebuild the library. A lot of work went into annotating it.

This is just another argument to buy something less cool, but that actually works…

Happy to upload a video if my description is not clear.

I wonder does anyone have any suggestions?

yep I am going threw the same problem as you. I did reported it to denon team hope they can come to a quick fix. trust me I know what you going threw I thought I had a fix using iTunes. however it all got messed up again there is no fix to it as I try for 3hrs trying to figure something out. we need more people to reach out so the dev team could come to a fix

Please forgive me, because English is not my native tongue, but by “threw” you mean “through”?

I sometimes still mix up “then” and “than” or “of course” and “off course”, but I’m getting there. :sunglasses:

1 Like

Hi Steven, do you mean you have no fix at all? I know how to fix this, but it takes some time (you do it track by track, and I think you are corrupting your EP library as you go…). I can post precise instructions if you want to.

I just reported this to Denon, too. Without functioning EP, the whole setup loses its appeal and advantage over competition. If this is not fixed I will really want to return it. I already do a lot of stuff in traktor (like using metronome on difficult tracks, checking bitrate). I might as well buy traktor’s gear…

my big issue is that my tracks don’t match when I add new tracks to EP. it seem to over ride my older track with different song title and let say if I have 100 tracks and add 20 more…it still say I have 100 instead off saying 120. it’s a hot mess but am open to suggestions if you have

You may have a corrupt database.

Why don’t you start afresh by deleting the database on both internal and external drive.

No need to delete the source tracks just delete the engine folder

Never thought about that will give it a shot. I never had this problem before. When the sc5000 first came out I never had this issues before. It worked great. But now that they integrated rekordbox an Serato something either broken or missing inside the software. But I will try to delete the old folder I have inside the usb and laptop. Hope what works.

Hi mufasa, this issue appeared minutes after I updated to engine 1.3. So I don’t think it’s the database itself - I think it’s EP 1.3. The files in the database - are correct and have correct tags. Only upon copying to the usb stick they become something else (and on the stick only - the original file in the database is correct). PLUS I do not want to delete the database - as far as I am aware, there is no way to keep my annotations, right? So tens of hours of work rating tracks, changing the genre, renaming files, correcting bpm, adding comments - will be lost. Do you know of any way of preserving EP metadata?

You can back up the database by renaming it or copying them elsewhere.

You will need to do it for the internal and external drive.

If you want to restore the old database just replace