Engine prime 1.3.3 & MCX 8000 firmware 2.1 Problems

on some specific tracks the mcx8000 does not show cue points

I have delved deeper into the problem and notice that it does not happen randomly as I thought, the tracks that in the mcx8000 do not show their cue points are always the same even if you delete the databases and do it again from scratch, if the tracks are loaded directly from the usb to engine you can see that the cue if they were exported correctly only that the mcx 8000 does not see them (I do not know if it is any detail in the export or the mcx) I attach some of the tracks so they can see that they have the same ones that cause this problem


the encryption key !n8LBKg_OUTjAhf_ZxGCeOA

I know I commented that the bugs for the mcx 8000 and the support for stagelinq were being solved (the latter for me is not very important as I commented in another thread), any idea if we will have this bugs solved before the end of the year


If only some special tracks are failing and yet the all your other tracks are showing cue points then I’d think it’s more a case of getting the tracks fixed rather than blame on the player.

the tracks have no problem, in fact I uploaded some to analyze them, the mcx 8000 does not show the cue although in engine if they are shown when loading the track from the usb correctly, in other equipment or softwares these tracks they have no problem, it is clear that something makes the mcx8000 not recognize the cue points only that I can not know if it is due to a problem of the mcx firmware or some detail prime engine when exporting


Yeah it’s the tracks. Something screwy with those particular ones. When some tracks just don’t behave like the rest , it’s the tracks - rerilp or redownload , remove tags and artwork.

Can’t keep blaming the Mcx. It’s days of being an easy target are over.

Check the tracks header info and if necessary repair it. This behaviour could be due to the vbr encoding.


ok then you can explain to me why in prime they are perfect as in rekordbox serato VDJ and pioneer equipment, even in denon sc5000, it is obvious that it is some detail or in the export or in the mcx8000, I am an electronic and computer engineer and I have worked as a sound engineer and dj with an experience of more than 20 years, so I think that separating and detecting the problems, the mcx is a great team but still has failures (in addition to the lack of the stage linq promised in its sale) if a track It works well in 9 teams and in 1 it is not obvious where the problem is


It’s those track files.

Try this: burn the faulty tracks to a CD then you rip them using your usual ripper then try adding cues.

Don’t rip to VBR only CBR

The burn and rip cleanse any faulty headers or corrupt heads

Is this with Serato or Engine Prime? And are these AAC’s by any chance? (file extension .m4a)

I have a number of tracks which have to be re-analized every time i launch serato. They play fine, but bpm / key / queue points never save when i close & reopen the program.

are mp3, leave the download links above, they are already analyzed and exported to mcx8000 by prime

Good to check the permissions in the files or if they are locked. I’ve had a few issues like this before over the years with random files and different softwares.