DB is corrupt. Please reformat and rebuild this drive


I’ve been mixing regularly off this Samsung T3 500 Gb drive for about a month.

I usually just cut the power on my players when I’m done. They seem to stay on long enough to unmount the drive properly, though I don’t think my (original) firmware does the 8 or 10 second red screen countdown as we saw in the demo videos prior to launch.

I never pulled this drive out uncleanly.

Today, I played through a couple tracks on my pair of SC5000’s and I suddenly got a popup letting me know I’m in trouble: “Database of T3 (Front) is corrupt and may not work properly.”

When I dismissed the popup on each of the players, I attempted a safe eject and reconnecting of the drive. Again, it reported the same message. In both cases, browse displayed my crates, but the right listing just let me scroll through endless lines, all empty. All that was visible were the thin dividers. You can actually see the track list in the background in my photo of the player. When I scrolled past it, all lines were empty. Scrolling back up, all lines are now empty, though the scrollbar indicates there is about the same huge number of tracks I had. When I swipe, I see the loading indicator, but the player is otherwise unresponsive.

Mounting the drive on my Mac has the filesystem come up apparently intact, but the Engine Prime software sees nothing more about the drive beyond the message: “Database of T3 is corrupt and may not work properly. Please reformat and rebuild this drive.”

Clearly something is wrong here, and I hope my description is helpful for Denon’s engineers. I wonder, though, if anyone else is having trouble like this. Perhaps my drive is at greater risk because it is so large? The drive (still) has 146 Gb of music, though many of them are FLAC.

Any hope of rebuilding the DB in place and salvaging my playlists?

Are there mitigation measures I could try, going forward?

Engine Prime Software Issue - Does not recognize tracks

I’ve sent a message to someone in the Development team for any suggestions, but you may need to wait until Monday/Tuesday for a reply. (I’m not sure how they’re fixed for online at weekends (officially they’re mon thru fri)

I would always go for the proper eject system at the end of your set, rather than just powering down and relying on the super-cap each and every time.


Thank you for that, Gee.

Yeah, I suppose that, at least, would be a good idea, going forward.


Having the same issue with a brand new Kingston 64GB Datatraveler drive. I ran all 8,144 Files (in 9,238 Folders for some reason, when looking at the drive properties) through Engine Prime, analyzed and even made a couple playlists and packed crates. Spent a few days doing this now with a couple drives, and playing on them…saving cuepoints without any problem. Problem was when I took my units out on the road for a demo with other DJs, one of the three drives all of a sudden had a corrupt database. Couldn’t read the drive the rest of the day (no biggie, had good house music on an SD card!). However, when reading the drive at home (again, fine on the computer, corrupt DB in Engine Prime). Even re-packed the crates that still existed. Then after safely ejecting (really learning that a lot lately!), no go again. Now reformatting and starting from scratch, but that’s hours upon hours lost - and this can’t happen professionally at events! EVER! SO…wondering if there’s any type of fix. Don’t want to have to “back up” every time I update. Going to put this particular collection on another SD card for the other unit for backup, but USB will be what I update and will depend on using. Can’t wait to hear more on this from the development team.


Forgot to mention, I did find this article about Library Optimization in the Knowledge Base: http://denondj.com/kb/article/2342

Perhaps this helps you, @thread. I personally didn’t know about these size (file quantity) limitations. I thought someone from Denon mentioned to me prior to purchasing that this new file structure (Engine Prime) had no limitations. 10K is what Rekorbox is limited to. Even the old Denon Dman tech was 50K! So don’t understand this at all. Not a total killer, but definitely a disappointment.


Another beef, rant, whatever you’d like to call it. So I reformatted, starting from scratch, and even though my entire collection has been scanned and analyzed (bpm, key and beat grid), it takes way too long to pack crates! And the fact that I can’t select multiple crates in my collection (since this process takes a long time), either with ctl or shift; I’d like to drag and drop, leave, and come back later and have it done, not have to come back to pack each crate. Sorry…will keep y’all posted.


Took overnight to load crates. USB 2.0. Might need to update to USB 3.0 to avoid this in the future. But having lost history, playlists, cuepoints, etc. Not cool. Will continue to re-build and going to experiment with copying drives for backup just in case.


Is anyone in this topic using external or third party conversion software to load their USB sticks from Traktor, Serato, Rekordbox - like Recordbuddy or that cheap recent conversion app ?


Not here. One more note. Some songs won’t load now, from the CF Drive I’m now using (since USB seems a little unstable). Might need to contact support if I can’t get answers here.


Rekordbox is not limited to 10K like you mention above, Some of their players like the XDJ-RX are whats limited.

I have 45,000 tracks in RB exported to a flash drive that plays on the NXS2 with no issues at all.


Exactly, for the external units like the XDJ-RX or the XDJ-1000s (stand alone).

Also, used to 50K max with the old denon stuff (DMAN Tech). So, just looking for improvements in the expansion department, that’s all.


Hi, I realise this is an old thread but has anyone had any answers or solutions?

I’ve had the same issue as the original poster. I have a samsung t3 500gb SSD. I don’t believe I’ve ever unmounted the drive incorrectly from the deck or the pc but I’ve ended up with a corrupted database message on the sc5000 and the engine prime software on the pc. The software had incorrectly analised the majority of my drum and bass collection, half actual bpm, wrong start point. so I’ve spent an insane amount of time sorting a huge collection of tunes out and creating cue points, I’m devastated I’m back to square one. If this can be a regular occurrence then there is no way I’m keeping the hardware, The decks n mixer are an amazing piece of kit but it’s not acceptable to lose everything like this…


Holy smokes that sounds terrible. I didn’t put nearly the effort you did in fixing my collection, but I have all the same issues. My dnb collection has the beatgrid correct maybe half of the time, give or take. These problems are straight not acceptable, and I’m only keeping my pair of the SC5000s because I know that Denon has a lot more riding on this than I do. I trust these issues will be worked out and eagerly await our first firmware update.

I can’t take this player seriously until we fix those 2 issues and a third I’ve had a handful of times where the layer wigs out – waveform still scrolls, but it drops into a pattern something like 7 seconds of silence, followed by 1 second of the tune playing properly, repeating.


I’m experiencing the same problem with a Transcend SSD. With SSD Sandisk, no problem.


Just started having this problem. I am using a SanDisk 128G thumb drive with under 2k songs. Using version SC5K & ENGINE: 1.2.0 for the past 3 months with no problems until now.


Gee, is there a solution for this? I just received the error message. I cant afford to lose my playlists and cues. Please let me know if there is a way I can get everything back and working again.


Hey KGBenny,

The solution comes unfortunately in the form of preparation and prevention. Here are a few pointers:

Make sure that you are on the latest version of firmware and software, as we are continually improving the handling of drives.

Make sure to eject drives properly before removing them from a switched on system. This applies to both the players and the desktop Engine Prime software. Removing a drive without ejecting can cause a database corruption.

Last but not least, if you want, you can manually back up the database. This can be done by zipping up all the .pdb files (but not the folder) in the Engine Library folder on your removable drive.

I’m sorry - there’s not much you can do for a drive that already has a corrupted database. I hope that these tips help you in the future.


So I had this happen to me once. I did not remove the drive while in use or anything. I plugged it in one day after using the drive on my PC, without engine prime running, and it was corrupt. I had no other option but to rebuild. Since then, once a month, I back up the entire engine prime folder to a zip, and keep it on the drive itself in the root. My hope is that if one day this happens again, I can restore my latest backup of the dB, and I can get back to operation, maybe having lost only my most recently added tracks since the dB backup. So far it has not happened again for me, but I hope this restoration works for me. On the same note, I have cloned a usb by copying the entire contents of one to another using Windows file explorer, and both drives work perfectly, so if you have a spare drive, you might consider backing up to another drive if it’s critical to have.


Any way we can get a read-only mode that just reads a database and saves nothing, not the analysis files, not cue points, etc? If not a setting, NTFS read-only mode would suffice and I’d just use the drives I use on the Gemini that will do that. Those players might be awful, but at least I don’t have to worry about them messing up a drive now when I use a 2TB NTFS.


I was able to replicate the corrupt DB message consistently on my Win 10 machine. It’s the only time it happens to me. When plugging into Windows, there is a pop-up that says “The drive is corrupt, would you like to scan and fix it?” (words to that effect anyhow).

Windows will complete the scan and repair successfully, but when you load it to Engine Prime it will say the db is corrupt. Rebuild your db and it works but if you scan and repair in Windows again it will not.

Hope this helps.