Cant get out of playlist on second deck



Interesting problem I keep having. In describing the problem, I refer to Deck 1 as the one with the USB device and Deck 2 is the one without the USB device.

I use deck 1 or 2 to go into a playlist and the other deck goes into the playlist too. I’m playing songs from the playlists on both decks. But let’s say I decide I want to play a song that’s not in my playlist. I use the back arrow beside the knob to go back to the main menu and, in order to clear the previous selection “tree”, I hold down the forward and backward arrows. At this point, I can now select any song in my entire library while Deck 2 is still playing.

The problem is, this only works for Deck 1. On Deck 2, I hold the forward and backward arrows and nothing happens. There is no way to choose any songs that are not in the playlist. Going into any of the categories (title, artist, album, etc), I find that I am limited to the what’s in the playlist. Selecting the “artist” category, for example, only brings up artists who are in my playlist.

As far as I can tell, there is no way around this on Deck 2. I even tried changing to CD mode and back again. So my question is, once I have selected and played a song from a playlist on Deck 2, how do I get Deck 2 to allow me to browse the entire library again? Looked in the manual and didn’t find anything on this. Any suggestions?


Jo, you should be able to do that without issue. How many files are in this particular Playlist?


I tried it with several playlists. The particular one that I was playing with when I decided to ask the question in the forums had 37 songs in it.


I know that this post is old however I am currently having the same problem (98% of the time). The other 2% of the time the second deck can make it to the main library, however when I attempt to select a track it simply reverts back to the " Title, Artist,genre" Menu.

This has been a problem at gigs as I can’t get to the next track I want to play.



I have the same problem when trying to look through “Crates”. But when I pull up “Playlists”, everything seems to load fine. Therefore I just don’t use Crates.


Well, after working with it since the new download yesterday i can no longer get to the main library on the second deck at all. I can however change to a different playlist (different than whats on the first deck) on the second deck. Still can’t get to main library.


Has nothing to do with linked players, it also happens with 1 USB Drive for each Player. There seems to be a difference in behaviour if you’r in CRATE ALL vs. HOME (after switching to USB Input) For example: CRATE -> ALL -> Search for genre (like limit to Drum and Bass) -> load track -> play Fine so far… now let’s try to switch to different genre: Hit back arrow -> select genre with knob -> Select different genre -> Stuck in Filter screen (no listing of Tracks from different genre) When doing the exact same steps in HOME most of the time it works but not all the time. Workaround is to clear all Filters by holding down <- & -> arrows which actually brings you back to init HOME without any filters set.

Playable with this workaround but clearly not how it should be.