Bug: Using Crossfader with Engine Lighting & SoundSwitch

I’m loving all the new features and fixes introduced in Engine DJ 2.0. The issue that I’m having is that Engine Lighting doesn’t acknowledge the crossfader change over between decks. What I have to do after crossfading between channels is that I have to also bring down the channel fader on the previous deck in order for the light show to switch to the playing deck.

I followed all instructions using Sync Manager per the online videos. Am I missing a step?

What Denon hardware are you using?

I’m using the Prime 4 with SoundSwitch’s original dongle.

Further research:

It appears that the default PERFORMANCE MODE for Engine Lighting is “Decks 1-4 / Upfader Only”. With “Decks 1-4” as the default, this locks out the options for Blend Mode, Cut Mode and Scratch Mode. See the SoundSwitch screenshot below:

NOTE: When using a laptop with the LINK you’re able to change to “Decks 1-2” and choose a mode other than “Upfader Only”. It would be great to have this ability as the majority of the time I do most of my mixing on decks 1 & 2 (80% of the DJs I know play this way). Also, I’m able to make Performace Mode changes on-the-fly while actively playing.

Not sure if it’s an oversight or should I submit this as a feature request. Some guidance or feedback on this would be greatly appreciated.

Thanks for pushing the technology, Denon DJ!

Hey Mixlive,

4 Deck mixing is the only supported mode at this stage. But that’s a good feature request. Something to work on for the future.

The fix would be to add the cross fader settings from the desktop software so that you can choose your mixing style.

1 Like

Thanks @Matthew.W for the reply.

I’ll submit a request to add other performance modes in a future release of Engine Lighting. :+1:

Hello,

i have a Prime Go and there works the crossfader, but i always disable the crossfader.

Problem is, that when the crossfader is on the left, and a song plays on the right deck, the lights are off. When the crossfader is in the middle, the lights are always half of the intensity…no solution.

The only thing is, that we can’t deactivate the crossfader for lights (lights should only react by the channel faders / not the crossfader).

Currently Engine Lighting is enabled for upfader (line fader) usage only. Not crossfader. I submitted a Feature Request to add crossfader in a future upgrade.

I still use the crossfader but you have to lower the upfader for the line not currently playing. That will then activate lights for the channel currently playing.

Crossfader on the prime go works…i can blend from left to right with the light…but this is, what i dont want

When the left fader is up and a song is playing on this channel (right fader is down) i can move the crossfader to the right and the lights fading the intensity to zero, this is what i dont want

We understand and as MixLive has said, a feature request has been submitted and its likely this will be fixed very soon

1 Like

if you are planning on changing it…make it optional…as i like the current way.

For cutting…i have the channel faders on full, so my lights come in full wack (how i like it)

If i’m mixing with channel faders, x-fader is in the middle (x-fader on sharpest) so there is no dip

1 Like

I’ve been in touch with @Matthew.W regarding this too. Prefer upfader over the need of crossfading (especially when crossfade it turned off in settings). I’m sure a fix will follow

This does not make any difference when crossfader is disabled on Prime 2 (or Go).

Currently Prime 4 offers upfader, Prime 2 and GO require to use crossfader and have half intensity when crossfader in middle

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.