BeatPort Link Not Working

Hi guys Tried using the beatport link Function in 1.5 on prime 4 i can login fine track data is showing try to load a track from any genre and this error.

i have doubled checked my subscription to beatport link and it is active on my account. internet is active via ethernet cable

Cheers team


I’m having the same issue.

People have mentioned in other sections hitting the settings cog while in the beatport source and then changing the bitrate to 128kbps. I’ve tried both 128 and 256 (I did beatport pro trial) and I’m getting the same error you get.

If anyone has some ideas I’d love to hear them!

Just gave it ago as well the cog to 128kbps also still same problem. i am also on the trial.

Have you tried switching off and back on again?

Bitrate should be set to the rate of the service you signed up for.

Can you play the same track(s) via the web site, or in VDJ, Rekordbox etc?

Most tracks play fine for me, but be aware there are bad tracks on the service (won’t load). I found some yesterday, and reported them. Next step is getting Beatport to believe me.

Hi All,

Thanks for reporting this. Devs are aware of this issue and looking into this. Bug report has already been filed.

I’m closing this one as it is a double post.