Beatport issue caused Prime 2 to become non responsive

Lucky just practicing at home not a venue. Not that I’d rely on streaming. Playing for about four hours off created Beatport playlists only. Went to change to a different Beatport playllist and instead of the usual blue “updating” message there was an orange one saying “waiting on Beatport” that never went away. Wouldn’t allow anything in Beatport to be selected. Did allow me to play off the SD card though. Went back a bit later and the “waiting on Beatport” was the same. Tried logging out of Beatport but after trying that the screen dulled out and was unresponsive with a spinning arrow. Stopped the tracks that were playing pushed the button to turn the Prime 2 off but that didn’t work either. Finally had to turn it off at the power plug. After restarting the Prime 2 everything seems to be working ok. Absolutely no idea what caused this. Has anybody else had this happen or any idea what could have caused this.

1 Like

I have experienced this on the 5/6000 as well. Unfortunately only a reboot clears that message.

It’s not right

could be a bug. when connection gets lost for a few seconds. I hope they will do a fix in the near future. Had this also on tidal.

Had the same thing happen yesterday. Didn’t lock things up this time just the blue “updating” message changing to “waiting on Beatport” that wouldn’t go away. I’m thinking it’s related to swapping between playlists with the message coming up above a selected playlist and prevents any selecting. Only option is to restart the Prime 2.