Very Satisfied but Have a few Questions


#1

First I would like to say that coming from a Nexus2 system I’m stoked at what the Prime system has to offer over the competition. I have been putting it through several hour long sessions and everything is working as advertised. When I received my system I immediately updated the 5000/1800 to the latest firmware’s. I would like to say great job Denon!!!

Now to my question, I noticed that when I turn on my system with or without the USB stick inserted and after I’m prompted to select the drive in which my music is stored, my player assignment numbers always revert back to 1/2 opposed to 2/3 that was saved along with their color assignments, I run both players through the 1800 usb hub and they are both plugged into their respective usb hub number. Therefore each time I confirm the usb drive that I will be using I’m required to go back into preferences/utility to change them back to 2/3 before playing. Am I missing something or is this the way it’s suppose to behave? Each time I change the color for both players and their assignments back to 2/3 I select the “Save to Drive” option at the top of the preference menu. Is it really saving these settings back to the USB drive?

Thanks in advance.


#2

When you insert the USB are you selecting ‘yes’ to loading the user profile from the stick? If so, this resets the player to whatever settings you have on the stick. I’ve noticed this with other settings, so it fits that it might apply to the deck assignments too - especially if the system looks and sees only two decks connected.


#3

@thorissr Do you mean the ethernet hub on the 1800?

I don’t have this issue, my left SC5k is linked to ethernet port 1 and the right SC5k to port 3.

My left player is assigned to channel 1 and the second layer to channel 2, while the right SC5k is assigned to channel 3 and that 2nd layer to channel 4 on the 1800.

Maybe that is also the case with your set up?


#4

That just may be it…I will plug my usb connections in the ports as you have mentioned to see if this is what I’m missing.

Thanks guys!


#5

Ok after trying every combination possible with plugging in each players cat 5 cable into the X1800 it didn’t work. I think the issue is with me…lol. Coming from the other side I’m accustomed to my player being assigned as such, player1 | player2 | MIXER| player3 | player4. With this layout your mixer chanmels corresponded with your channels. So my channel faders that i used were channel 2/3 for the 2 players closed next to the mixer.

So I need to change my way of thinking that reflects my players are numbered based on how many physical players I have hooked up, in my case I own 2 players therefore the naming scheme will always be simply player 1 and player 2. With my previous nexus2 system when using pro dj link (Ethernet hub) my 2 physical players were always 2/3 as outlined in my example above.

Thanks everyone!


#6

Which LAN port you plug each Deck LAN into will allow you to dictate which Deck and Layer go on which mixer channel.


#7

Ah!!! Makes sense now. Thanks for the visual…lol. Because of my previous hard to break habits with your competition’s hardware I’ve always used channels 2 and 3 on my mixers for a 2 player setup, which aligns with my example in my earlier post…player 1, 2 Mixer 3, 4 design. I’ll continue to use the setup that allows me to play with mixer channels 2 and 3 until I’m ready to retrain my brain. My mental adjustment will be that my player numbers will now always be player 1 and 2. In order for my players to show up as player 2 and 3 I’ll be required to use the outer most channels on my mixer, so I’ll just keep it as is for my sake. Making a mental adjustment for players numbers is easier than making a psychological engrained adjustment for my workflow on my mixer. This really helps!!! Thanks everyone.


#8

Am I missing something, because you can still do that. Both A layers can be ch2+3. Just connect the two decks to Ethernet 2+3. Both B layers will become 1+4, but if you don’t use them keep it as single layer devices.


#9

Correct that’s how I have it setup now and when I initially posed this question. I can used channel 2 and 3 on the mixer by plugging into ports 2 and 3 on the x1800, but the confusion came when I noticed the actual player numbers on my sc5000s were showing player 1 and player 2. My thought process was your port/mixer assignments would correlate to each players numbering scheme.

The diagram provided by @Gee in this thread reflects what the problem was for me and made me thinking I was going off the edge.The numbering scheme from the ports asignment > mixer channels > sc5000 player assignment (actual number on the player screen) will not correlate with one another. Example: if I plug the cat 5 into port 1 it utilizes channel 1/2 with layer A being assigned to channon the mixer. My thinking was that if I plugged it into port 1 it would use and I could manually assign channel 2 to be layer A and layer B to channel 1.k

Quite frankly the culprit to my way of thinking was the dual layers on the sc5000s. We all know that the competition doesn’t have dual layers and their players are always a 1 to 1 match. With their players I would plug in my cat 5s into a Ethernet hub along with their flagship mixer and when using only 2 players they would be assigned to channels 2 and 3 on the mixer via rca cables and when you assigned your players manually in the utility menu as 2 and 3 this setting stuck and each time I rebooted or turned on my system by default I would see player 2 (left player) and player 3 (right deck). Like I mentioned I have to retrain my brain that due to the dual layer functionality I will not see player 2/3 as my primary Layer A decks.

I know this may be confusing but I now get it and have no qualms with th numbering scheme with having 2 physical decks and 2 virtual decks (4 decks total). Now if I ever decide to go with 4 physical players I’m pretty sure I’d be back…lol!

Thank you everyone for contributing and assisting me through my confusing moment!!