Effect Knobs Delay (Solved)


#1

jackleather

18 Mar 2013 12:05

Is is normal for the effect knobs in traktor (2.6.1) to lag behind the real-physical knob on the MC6000 (with latest firmware)? in other words when i turn the effects knobs the knobs on screen don’t turn at first - after a few ‘wiggles’ the on screen knob mirrors the hardware. Last edited by jackleather on 19 Mar 2013 10:45, edited 1 time in total.

DJ_Boothe

18 Mar 2013 14:19

Is it actually a delay - or is it more that Traktor seems to “lose” touch with where the effects knob is.

For example… If you turn an effects hardware knob all the way round to “high”/“max” before you even open up traktor, then open traktor up, does Traktor think the knob is set elsewhere for a while, then it works out where the knob really is once you start moving it? As a test, for example, your comment above about “After a few wiggles”…does that still hold true if instead of “a few wiggles” you simply rotate the knob calmly a few degrees (so that traktor can see any movement, rather than a stationary control/encoder)

If it is a delay, what sort of delay are you seeing? half a second? a second? Is so, do the other controls (like the channel faders, EQ knobs etc) show this same delay, or are they more responsive?

jackleather 18 Mar 2013 14:34

Thanks for your consideration Gary.

Basically the ‘delay’ is intermittent. when i say delay i don’t mean like latency. once the physical and on screen knob sync they stay that way until I change the effect (e.g. reverb -> flanger) then its likely to do it again. its as if traktor sometimes ignores a knob turn - i have to turn left and right and back to get any response.

For example… If you turn an effects hardware knob all the way round to “high”/“max” before you even open up traktor, then open traktor up, does Traktor think the knob is set elsewhere for a while, then it works out where the knob really is once you start moving it?

if i set the hardware knob to max (right) and then start traktor the on screen knobs are set at minimum (all way left) and they stay that way if not touched. for the hardware knob and on screen to sync i have to rotate to the minimum setting (thats where the on screen knob is positioned).

More importantly the actual sound wont change until hardware knob meets screen knob.

so its not really a delay more a synchronization issue. FYI i have disabled the ‘restore parameters when switching fx’ option which improves things as when i change the effect (eg reverb->flanger) the parameters dont change to the previous value.

so to conclude; in order for the knobs to sync i must rotate the knobs to the same position as the on screen counter part then they stay together. further more this occurs with gain/low/hi etc also

robdquick 19 Mar 2013 09:53

If you really want the knobs to respond immediately, there’s a setting in the mapping that will do this.

In the controller manage, select the mapping for the MC6000, find the control you want to change (I think it’s called FX amount) and highlight it. At the bottom of the screen there a tickbox for soft takeover. If this is ticked, then that’s the problem, as traktor is waiting for the knob to return to the position that it is on the screen before it moves. If you untick this box, it will move instantly to wherever the physical knob is. You will have to do this for all 6 knobs if you want to change them all.

Bear in mind that by doing this, it will instantly jump, and this could be bad if you have an effect engaged at the time. For example, if you have an effect on at 0% in the software, and the physical knob is at 100%, as soon as you move slightly down the knob in the software will jump to 99%. Not too bad if you have something like a flanger or iceverb engaged, but potentially disastrous if you have something like beatmasher engaged!

jackleather 19 Mar 2013 10:44

thanks for your example! so what I am seeing is a feature called ‘soft take over’ and it makes a lot of sense now i look at it this way. :smiley: