X1800 Frozen at startup with all lights on !HELP!

When I went to turn on my x1800. Ever light came on except for the OLED screen and the instant button on the bottom right of the effects. Anyone else have this problem? Anyone know a fix? I contacted tech support 3 times but they don’t seem to want to reply…

Don’t make doubles, please. (@Reese - can You merge his two topics, that are exactly the same?)

I only made a duplicate because it wouldn’t let me post the video from a new account. I’ll delete the other one. Some help on the ACTUAL problem would be nice as opposed to criticism on a double post made because of the posting guidelines :roll_eyes:

Has this just happened completely out of the blue? This is not the result of trying to update firmware?

How did you contact support? Was it here -> https://www.denondj.com/support ?

BTW your account is not new. You signed up more than a year ago, and posted a few times.

If there was a ‘low post count’ restriction, you just needed to post a few more times (comment on some threads) - not duplicate what you’d already posted.

I had played on it 8-10 times with 3-4 of those times being about 4 hour sets SINCE updating the firmware so I don’t think that had anything to do with it. It’s hasn’t been dropped or gotten wet or anything. I just went to turn it on a few days ago and this is what happened.

And yes, that’s where I contacted support.

Also, I’m aware of how old this account is. I deleted the other post. I had made a new account not realizing I wouldn’t be able to post the video. When I learned that I logged into my old account so I could post it. I didn’t realize it was gonna be such a big deal but the other post has been deleted.

You might want to try reloading a firmware (same, newer or older) again, to try and reset it.

The computer doesn’t see the mixer when plugged in. And I’ve tried to do a reset on it and it still just lights up like that. Unless there is another way to reset it that I don’t know about?

According to Google it’s: “Power on the device while holding BACK + FX CUE + TAP

Yep tried that, same result. Like it’s not even trying to boot up. It goes straight to that every time

Try using another laptop and cable if you have them. This has happened to me twice now and is currently away being fixed. Hope you have better luck than I did

It should do a led wave, not like shown in the video. I’ll tag someone to get support.

@RYNOGOD - Sorry to hear of the trouble. When you power on while holding BACK + FX CUE + TAP, what does it say on the display?

Nothing. The display never comes on. It does exactly what it shows in the video no matter what I hold when I turn it on. Tried 4 different computers (2 pc and 2 Mac) that have had the firmware update deleted and redownloaded onto them , 4 different cables, and both USB ports on the mixer. No computer is seeing it. It’s doing exactly the same thing as shown in the video regardless of anything I’ve tried thus far. Thank y’all for the help @JWiLL @Reese

Is it still under warranty? If so, contact them and let them know what’s happened. If not then you’ll have to contact Denon Support like I was advised.

Understood. Thank you for the additional detail.

Have you heard back from the support team yet?

Yes but the advice given was less than has been given on this forum. They just suggested I change the power cables.

Ok, understood. Please DM me your contact details (full name, tel, email, country) and I’ll look into your case a bit to see if I can help.

@JWiLL done. Thank you.