X1800 for streaming doesn't work sometimes

Hi! Something very curious happens to me with the X1800.

I put a USB cable from the X1800 to the laptop. Sometimes the OBS detects me a signal, and sometimes it does not.

I don’t know if there is a protocol to follow (first turn on the mixer, then the laptop and then the OBS or first turn on the laptop, then the mixer and then OBS or …).

Because I don’t understand that sometimes it works and sometimes it doesn’t, and I don’t touch anything. It’s very weird…


Are you always using the same USB port on the x1800? Always the left one or always the right one ?

Have you tried to refresh the source in OBS

Click on properties select the sound card again.

I have a UCA 202 permanently connected to my streaming PC. I noticed the things that I remove sometimes and reconnect lose connectivity. Eg the cameras

Yes, I have disconnected, reconnected, told the OBS again to choose the Denon, etc … but nothing …

Are you using the broadcast mode on the mixer?

Yes, I always use the one on the left.

And yes, I using mode on on the mixer.

Try the sequence

  1. Mixer on
  2. USB connection
  3. Start OBS

Maybe that will work

Is Mac or Windows

Ok! I try.

Although I have tried so many things, that surely I have already done it like that, but I will try it again. Thanks!

Just tested repeatedly with Streamlabs OBS, various sequences.

  • SLOBS first, connect USB.

  • Hot unplug and reconnect

  • Mixer first, start SLOBS

It connects.

On Mac that is.