X1800 and Audacity connection setup. I need help

I still can’t get it to work. My Mac is seeing the input but rekordbox or audacity can’t find. Very weird.

Did you set up 10 channels ?

No option for 9 or 10 in rekordbox or audacity. I was able to set it in live though.

Dunno what step you are missing. I will record a video of how things look on my end.

Not sure either. Never had a problem with recording with other mixers and controllers. Just received the x1800 and did every step you put up and nothing.

Same, I just plugged it in selected the right sound card and clicked record, it just worked.

Here ya go

A video of how things are

I didn’t do anything special here.


Thanks man! I never hit record in audacity. Was looking for the signal in the preview. It works now.

1 Like

This is what I get???

MME needs to be something like ASIO. What options do you have in that dropdown menu?

While you’re at it, make screenshots of the other dropdown menus also. Especially the device with multi channel.

I have windows Direct sound and WASAPI and the screenshot are on all the modules the same.

And this is … (Audacity?) on Windows … (version)?

Let me know and I’ll try to replicate it here.

Audacity Windows 10 PRO Audacity 2.3.2

And then there is this solution:

Non-distributable ASIO support in Audacity

Audacity provides ASIO support on Windows for individuals who are prepared to compile Audacity from source code using the optional Steinberg ASIO SDK.

ASIO support is provided strictly on the basis that it is NON-DISTRIBUTABLE , that is, you may NOT copy or distribute builds including ASIO support to anyone else. The build is strictly for your own personal (private or commercial) use. For the same reasons, Audacity can NOT distribute builds of Audacity including ASIO support, so please don’t ask!

The following is an overview of compiling Audacity from source code including ASIO support.

  1. Install the free Microsoft Visual Studio Community Edition Integrated Development Environment (IDE).
  2. Download and install the ASIO SDK from Steinberg.
  3. Download the source code of the latest Audacity release from https://github.com/audacity/audacity/releases. Follow the steps in win/compile.txt in the source code to:
  4. Download and install the wxWidgets GUI toolkit then build wxWidgets using Visual Studio.
  5. Set the WXWIN environment variable to the directory where you installed Widgets and set the ASIOSDK_DIR environment variable to the directory where you installed the ASIO SDK. Reboot the computer.
  6. Build Audacity using Visual Studio.

Follow the instructions and download links on Developing On Windows in the Audacity Wiki for full details.

But quite difficoult to achieve.

I really still don’t understand all the problems people are having. It’s definitely not a mixer problem.

Installed Audacity 2.3.2 on my Windows 10 Pro. Connected the X1800. Started the program and opened preferences:

Same input/outputs if I choose MME, DirectSound or WASAPI. ASIO seems not needed.

And I at least have 4 different audio interfaces; onboard Realtek, RME Fireface UC, D&R Airlite mixer, DenonDJ X1800

When I hit record I get a 90000x error with: Device not setup properly??

If you have the 1800 drivers installed the 1800 shows up in Windows device manager as a standalone device, not an audio device, that’s how you get the list of channels @Reese showed above. If you don’t see that list make sure the drivers are installed, you may also need to make sure you are using a compatible USB cable, cheap cables tend to cause problems with USB audio devices including your software not being able to connect to them. Once you do get the list of channels it’s 9/10 that you want for master.

I use the cable that has been delivered with the mixer so I don’t think DenonDJ would send a incompatable USB cable. Then The mixer shows up as standalone audio device and all the drivers are installed. Still no channels are popping up and this is all I get in Windows10 pro.

Make sure X1800 is not selected as default windows audio device. Windows never liked to share it’s audio devices with other aplications.

What am I doing wrong?

Nothing. You need to take it up with Audacity. The X1800 Prime works. What if you select and record from the Realtek interface?

Error 9999 seems to be very common with several possible solutions, but it seems only a few are successful.

Some seem to have problems after Win10 build 1803. I hope you have updated to higher than that old build, however they talk about making this setting active:

^^ CONFIRMED: if I set it to off error 9999 appears!

It even mentions something at the bottom of this setting screen…