X1800 and Audacity connection setup. I need help

This is what I get???

MME needs to be something like ASIO. What options do you have in that dropdown menu?

While you’re at it, make screenshots of the other dropdown menus also. Especially the device with multi channel.

I have windows Direct sound and WASAPI and the screenshot are on all the modules the same.

And this is … (Audacity?) on Windows … (version)?

Let me know and I’ll try to replicate it here.

Audacity Windows 10 PRO Audacity 2.3.2

And then there is this solution:

Non-distributable ASIO support in Audacity

Audacity provides ASIO support on Windows for individuals who are prepared to compile Audacity from source code using the optional Steinberg ASIO SDK.

ASIO support is provided strictly on the basis that it is NON-DISTRIBUTABLE , that is, you may NOT copy or distribute builds including ASIO support to anyone else. The build is strictly for your own personal (private or commercial) use. For the same reasons, Audacity can NOT distribute builds of Audacity including ASIO support, so please don’t ask!

The following is an overview of compiling Audacity from source code including ASIO support.

  1. Install the free Microsoft Visual Studio Community Edition Integrated Development Environment (IDE).
  2. Download and install the ASIO SDK from Steinberg.
  3. Download the source code of the latest Audacity release from https://github.com/audacity/audacity/releases. Follow the steps in win/compile.txt in the source code to:
  4. Download and install the wxWidgets GUI toolkit then build wxWidgets using Visual Studio.
  5. Set the WXWIN environment variable to the directory where you installed Widgets and set the ASIOSDK_DIR environment variable to the directory where you installed the ASIO SDK. Reboot the computer.
  6. Build Audacity using Visual Studio.

Follow the instructions and download links on Developing On Windows in the Audacity Wiki for full details.

But quite difficoult to achieve.

I really still don’t understand all the problems people are having. It’s definitely not a mixer problem.

Installed Audacity 2.3.2 on my Windows 10 Pro. Connected the X1800. Started the program and opened preferences:

Same input/outputs if I choose MME, DirectSound or WASAPI. ASIO seems not needed.

And I at least have 4 different audio interfaces; onboard Realtek, RME Fireface UC, D&R Airlite mixer, DenonDJ X1800

When I hit record I get a 90000x error with: Device not setup properly??

If you have the 1800 drivers installed the 1800 shows up in Windows device manager as a standalone device, not an audio device, that’s how you get the list of channels @Reese showed above. If you don’t see that list make sure the drivers are installed, you may also need to make sure you are using a compatible USB cable, cheap cables tend to cause problems with USB audio devices including your software not being able to connect to them. Once you do get the list of channels it’s 9/10 that you want for master.

I use the cable that has been delivered with the mixer so I don’t think DenonDJ would send a incompatable USB cable. Then The mixer shows up as standalone audio device and all the drivers are installed. Still no channels are popping up and this is all I get in Windows10 pro.

Make sure X1800 is not selected as default windows audio device. Windows never liked to share it’s audio devices with other aplications.

What am I doing wrong?

Nothing. You need to take it up with Audacity. The X1800 Prime works. What if you select and record from the Realtek interface?

Error 9999 seems to be very common with several possible solutions, but it seems only a few are successful.

Some seem to have problems after Win10 build 1803. I hope you have updated to higher than that old build, however they talk about making this setting active:

^^ CONFIRMED: if I set it to off error 9999 appears!

It even mentions something at the bottom of this setting screen…


I will try your solution out as soon as i have time!

Geen probleem!

Ok I can now record, But I cannot record multiple faders into one channel. I tried to go into the mixer and set everything to CH 1/2 Did not work cause still the other faders are recognised as 3/4 or 5/6.

Fader 3 5/6

Fader 2: CH 9/10

Settings in the mixer:

Anyone can explain what I am doing wrong now?

You do want to record the sum (=mix) of all 4 faders of the X1800 or not? Then only record ch9/10 in Audacity.

Keep everything in the X1800 set to default so:

  • CH1 assign > 1/2
  • CH2 assign > 3/4
  • CH3 assign > 5/6
  • CH4 assign > 7/8

Working fine now. Big thank you. Biggest.problem was microsoft.

1 Like

Pfwew. Took us a year to get it sorted for you! :grimacing:. Thought about driving to Middelburg for this.

Yeah the Microsoft microphone switch was the base problem.

Nice one. Please mark as solved to let the admins archive this post.

Also, you need to set the mixer back to factory settings. To be sure it does it like that.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.