Wrong BPM in collection. Correct when loading the song

This text will be hidden* Software or Firmware Version: (1.2, 1.3.1, etc…) Engine Prime 1.6.1

  • Expected Result: (ex: It does X…) It shows the same BPM both in library and when loading the song.

  • Actual Result: (ex: It does Y…) It shows 39 BPM (which is super off) in the library, and 119 BPM when loading it.

  • Reproducibility: (ex: Happens 1 out of 10 times.) 10

Hello @vegaro, Welcome to the forum.

Could You please add some more details, about what happens when You load the song?

Does Engine analyse the track on load up?

Thanks @NoiseRiser . Sorry I wasn’t very clear. The track is analyzed in Engine Prime. When I see the track in my collection, it shows it is 39 BPM. The problem is that when I load it in the player, it shows 119 in the grid edit section. It happens the same in my Prime 2, it shows 39 when browsing the library, and then as soon as I load it, it says it’s 119. I’ll see if I can upload some screenshots, but I don’t think I can because I’m new to the forum.

No need to, I understand Your issue. There are many things that can cause this. One of them could be id3 tags. Did You tried maybe to edit the id3 tag outside of Engine prime? For example withsome media players like itunes or some other program???

I imported the song from Rekordbox, after analyzing with Mixed in Key (like all my songs), but I just checked the ID3 tag (which btw is v2.4.0), and BPM is not set.

I managed to take a screenshot:

I am not sure if the v2.4 of id3 is or not compatible in Engine Prime. Maybe @mufasa can help more in id3 tags?

Try reanalysis in Engine Prime for the tracks

Reanalysing fixed it! May I ask, do you know why did the first analysis not analyze it correctly? It has actually fixed other songs with the same issue :thinking:

  1. The first Analysis in EP - will use whatever bpm rekordbox has for the track

  2. “Reanalysis” will recalculate the bpm using Engine Prime’s improved algorithm.

In Summary, have Autoanalysis on in EP settings, then “Reanalyse” again after the first analysis.

  • Also check in MIK that you have enabled MIK to write its analysis to tags. Maybe thats why in the second picture you dont have BPM values.

1 Like

The standard is still id3Tag v2.3!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.