Windows not recognising mc4000

hi! when i plug usb cable in to the controller only load prep, back, load 1 and 2 buttons light up and windows cant install drivers so unknown device shows for mc4000. i tried different cabels and usb ports with no luck. i also reinstaled usb drivers. controller was working fine till suddenly this happened…i also tried reinstaling firmware bud culdnt cecause controller is not recognised. how can i fix this? ty

Are you sure the usb port is not damaged? Or the usb cable?

Yes, i tried several. Nit shure about port on controller

Perhaps try uninstalling the device drivers and then re-installing them. You can do a web search for the ‘how-to’ on this. Below is what I found:

Start with the controller unplugged from your PC.

On your Windows PC click Start, type Device Manager, and press Enter. Find and double-click the category of device whose driver you wish to uninstall (for example, the graphics card would be listed under Display Adapters). Right-click the device , and click Uninstall . Windows will prompt you to confirm the device’s removal .

After doing the above, plug your controller into the laptop and it will usually recognize it as a new device. You PC will either search for the drivers or prompting you to install them. Reinstall the drivers and hopefully all will work.

Good luck!