Win 8 (64): Engine 1.5.2 crashes

Repeated crashes at start: Fixed reinstalling multiple times with administrator rights During engine crashes, 74% crashes … not resolved Any help?

What helped me (thanks to @RabidRabbit) was deleting the DENONDJ2 folder (or renaming it if you want) in the rootfolder of your hard drive (typically it would be C:). Then run Engine again. It solved all my crashing problems.

it helps… maybe… a litte bit… for a short time…

it’s SO frustrating. payed hundreds of euros for denon equipment and tryed to run engine under win7/32, win7/64, win10 and mac-os…

it’s a shame, sorry to say :slight_frown:


The good news is that with the new Engine Prime a new version of Engine is on the horizon too.

I am expecting a new version of Engine that will take care of many of these issues.

1 Like

I did not fix it, engine crashed again :frowning:

What is the source of your tracks? What format are you using?

Engine crasches during scan at 57%…at 74%… Only original mp3 buy on ZipDJ, Beatport, Traxsources, Itunes, Juno ecc… All files are divided into folders in documents, the only thought is that the folders are already all analyzed with traktor … but should crash on each folder … or the library is too large Individual folders seem to be successful … just small ones :confused: This maschine: win8(64)pro, admin right, no antivirus found, system free, no internet connection etc…(I’m a technician) Is a dedicated pc. Engine very instable at install & after., freeze my cpu during scan :confused: (Serato instead completed the scan) Unfortunately only on this pc i have win 8

Hopefully one of the Denon techs here can help you with some more tips. I assume you did all the Serato and MCX8000 improvement tips?

I installed Serato later …I started with Engine, i’m working :wink:

I started with Engine … Just after I went to Serato, now I’m working :wink:

1 Like

Engine crasches during database creation… solved only if analyze subfoulder…(with db bachup… no autoanalyze :wink: ) I am expecting Prime… :confused:

This Engine software is a joke really. I’m laughing very hard on it. I have not been able to analyze 60 tracks one single time, on several different systems. Constant crashes!! How could they release such a piece of crap is beyond my understanding really!

1 Like

If it’s happening across multiple systems I’m willing to bet it’s one of your files that’s the issue :wink:

Oh you think one of my files is corrupt and cause crash in Engine 1.5.2 ? Then I can tell there are not the same files tried to analyze… I have uninstalled Engine from all systems and hopefully there are no trace left of it anywhere still. I’m putting my hope into new release of Prime with MCX8000 support :grinning:

If you just did a regular uninstall it’s not enough, some files remain. Also, I did read that one user reported that he also had problems with Engine 1.5, couldn’t get it to start. He later installed Engine Prime, just out of curiousity to see how Denon improved it and then had no more issues with Engine 1.5.

The explanation is that Engine 1.5 depends a lot on windows OS and other external files (for example Quicktime is required for audio processing) while Engine Prime installation probably brings it’s own codecs that update the existing ones in the system.

Try using a cleaning tool to remove all traces of existing Engine 1.5 instalation (registry items, database files). Install again and try installing Engine Prime, maybe it helps )I doubt it can hurt).

For cleaning it is certainly useful to use tools … see Revo, Iobit, Ccleaner, Glary…etc. Erase the database to regenerate it can be useful but sect Engine to remember the analyzed files … you need more steps to finish … let it work … the soft is quite unstable, it gave me so many crashes, you have to proceed a bit 'time and this is unacceptable for a soft fundamental to the MCX8000… grrr… Installing Prime in the registry I do not think it’s a good idea if you do not have the necessary hardware to run it. Quicktime is required for audio processing? … I do not think … I do not use it at all … I codify with Lame codec and more …

It seems certain tracks do crash Engine (although they meet the criteria) but not sure why. Could be metadata or album art … who knows. I did send a track to support some months ago but they stopped responding to my emails.

The only way round it (although it’s painstaking and will take literally days) is to scan in batches of 25 or so and keep an eye for the track it freezes on. You then need to remove the offending file from your library and run the batch again until it eventually builds a database of sorts on the memory stick.

Above that, Engine also freezes on startup and when scrolling so it’s pot luck whether it will work or not. Personally I have abandoned MCX8000 standalone mode which is a shame as it has so much potential. As you know, Denon are working on both prime support and updated firmware but it’s a year and a half since the product came to market so read in to that what you will.

I’m really disappointed with this but there’s nothing we can do.


If it consistently crashes at x% of the way through, it’s probably one of your music files. Maybe it’s in mono or not 44.1khz or an .ogg file or something weird like that. I would take all of what you’re trying to import and convert it to the Engine standard (2-channel stereo, 44.1khz, MP3 or WAV only) with a program like dbPowerAmp and once that’s done, try re-importing the files. I was having this happen the first time I imported tracks and it turned out to be two bunk files hosing things up. Just something to try while we’re all waiting for this Engine Prime stuff to actually happen.

I will back this up.

My example: I started with Traktor library that was carefully groomed: all tracks were mp3, 44.1khz and stripped of all metadata on download. Reset the id3 mp3 tag with neccessary info (no cover art) then imported into Traktor. When I had Engine 1.5 (and later this year tried Engine Prime) I did not had a single issue when I imported tracks those. Not once. It cannot be a coincidence.

All my tracks are mp3 44.1 with clean ID3v2 tags so it can only be the artwork or some other gremlin. Haven’t had the time or inclination to try and figure it out more.

As I said above I sent a track to support but they stopped responding to my emails when I asked them what was going on. Only ever got the usual been reported we’re working on it which isn’t a solution for the end user.