Update 2.0 does not load on the x1850 USB1 Port

Tried to update software and it will not recognize USB1. It will recognize Usb 2 but once it starts the download the mixer does not respond as if its taking the update then just stays in data receiving mode with not update.

Mac or Windows? If in Windows have you installed the correct driver before running the update?

1 Like

I presume there’s a typo in the title. The mixer’s firmware is 1.5.

Advise is to remove previous driver and updater. Install the latest version after that.

Ultimately, if you can, try another USB port or another computer.

I got rid of the old updater and reloaded to new one. However it appears that I can’t get my Mac or My PC to recognize the mixer USB1 port. It will start the update from USB 2 but the mixer doesn’t show it accepting the download and when its finished it doesn’t restart. Its like USB 1 is off somehow.

Could be a hardware issue indeed reading your comment if port2 does work.

Not much other things to try. Other shorter cable maybe.

@Anthony_DDJ > techsupport?

1 Like

Hey @DJSpartaxxl - Sounds like we need to get you connected with a technical support agent. Please feel free to send me your information via DM (email, full name, phone number). We’ll be happy to get this sorted.

Took me 3 attempts to update my 1850 to 1.5 earlier today

Tried a different usb socket on Mac third time but this have been coincidence?

Keep trying and hopefully it’ll work