[UNDER REVIEW] Prime go deck 2 freeze

  • **Engine OS Device: Prime go

  • **Beta Version: 1.6 beta2 public

  • **Steps to Reproduce: start up Go. Login to Beatsource, load track deck 1 and 2.Start playing deck a1 no problems, start playing or cueing deck 2, won’t play. Tried beatport and from usb, deck 2 won’t start.

  • **Expected Result: deck 2 should play

  • **Actual Result: won’t play

  • **Reproducibility: first time thats happened

  • **Additional Notes

  • **Link to Video Repro:

8 Likes

I had this happen once as well after updating to OS1.5.2

2 Likes

Thank you for taking the time to provide this bug report.

We will investigate and let you know if we need any further details.

2 Likes

I also had this bug yesterday on 1.5.2. Only on deck 2. It was resolved after restarting the device. I loaded a track, but it would not play and I could not use vinyl mode to scratch either.

Had the same problem. I sent it in and got a replacement unit.

I have had this happen since upgrading to 1.5.2

Only on Deck 2.

Happened three times in one hour this morning.

Rebooting the unit is the only way to resolve the issue. Not ideal.

Please look into this and do something about it with an update.

Thanks.

1 Like

Lots of people reporting this issue with the Go now.

Some new posts on the official Denon Facebook page about it.

Basically, it’s very random. Load a track into Deck B and it freezes. Hot Cue doesn’t start the track. The Play/Pause button stays solid green but there’s no playback. Waveform doesn’t move. Loading another track into the deck results in the same issue.

Only way to get it working again is to reboot the unit.

As said, it’s a random error. Can go hours without it occurring and then the next time you use the unit it happens.

I’ve only had my Go for two weeks and it’s happened 6 times.

I just want to be confident in my gear and for it to work as it is intended to work.

Please Denon, sort this out quickly.

Hi just received my prime go yesterday and downloaded the latest firmware and now the deck 2 keeps freezing. Only way I can fix it is by turning the unit off. Will there be a fix to this soon or should I send the unit back?

Happens on 1.5.2 also. Only happened twice but you could say two times too many. I am sure a fix will come.

Same issue x2 on Win10. Reboots were needed. Finally updated to 1.6 Beta. Not occurring any more.

https://denondjforum.com/t/prime-go-right-deck-wont-play-after-loading-song/25094

Here’s a short video I made of the issue. I was using a friend’s phone, so sorry for it being upside down.

Important points:

  • Hitting Play will change the “Mode” of the button, from flashing to not flashing. It won’t play the track though.
  • The software does know the current mode though, because it will refuse loading a new track into the deck if it’s “playing” (or rather not playing).
  • Hot cues do jump to their position, but won’t play which would normally happen with my (standard) settings.
  • I can put down a (white colored) Cue with the big Cue button, it will also jump to the cue if the deck is in “playing” mode. But it won’t play if I hold down Cue, which would normally happen.

Pretty sure this is a software bug, because the software clearly knows if the deck is “playing” or not. Already had this issue on 1.5.2.

Hope this helps. If Denon needs me to do anything else please do ask, because I really don’t want to send in this otherwise amazing piece of gear because of a supposed software issue.

5 Likes

This looks like the jog wheel thinks that it is being touched on deck 2.

Have you tried to recalibrate the jog wheels in setup? Is the power cable connected to an external power source?

Dodgy power grounding can interfere with the capacitive jog wheels so it is worth trying that.

I tried with and without external power. And as explained by me and others this sometimes happens and sometimes it just works fine. This error can appear with or without power plugged in, for me.

There is no in-between where it half works. Which is why I doubt it’s a jog-wheel issue, at least on the hardware side. I also had this problem already before I started using vinyl-mode, so touching the jog should in this case not have stopped the track.

I’ll try this when the error pops up again, later today most likely, turn off vinyl-mode to make sure that’s not the problem.

1 Like

Yeah, I’ve had it happen for me on the Prime 4 once which is why I asked. It kinda rules a few things out and narrows down what mode it is in when it fails. There is no in between which is why I thought it could be the vinyl mode. Once that is eliminated, it is a case of looking elsewhere.

The issue where touch doesn’t work can be intermittent and seem random on capacitive jogs as static plays a part.

If the deck appears to function like it is playing a track but is in “pause” it usually points to the unit thinking that there is a hand on the platter in vinyl mode.

I could be totally wrong with the Prime Go but it seems to exhibit the exact same symptoms as grounding/static issues as the jog wheels use conductive charge.

I have had this before on the P4, the MCX8000 and also the Pioneer DJ SX1. I used to calibrate the unit when it happened (the SX1 was manual with a physical pot control).

Just a thought to narrow it down.

Is this the same issue? Prime go Problems after 1.51 update

This seems to be a solution… hold your hands on the jog wheel when powering up. As there is no calibration option in the menu for the Prime Go then it could be worth giving that a go as it seemed to have worked for someone in that thread.

Very helpful, hopefully. Thank you. Seems to be the same issue, although that thread is lacking in details.

I’ll experiment a bit to see if it really seems like a problem with the capacitative wheels.

But let’s say I deactivate vinyl mode and the issue persists, would that not rule out a capacitative issue, unless it’s a combination with a software issue and/or an issue with the vinyl-mode button?

1 Like

If the issue persists with vinyl mode off I think we can rule out the capacitive touch jogs. It seems a common issue where the jogs get a little crazy when static or moisture are around. I used an outlet in a bar that I worked in that didn’t have a good ground connection and my MCX8000 used to go crazy on the jog wheels.

Hopefully this works but if not I’m sure someone will be able to help from support. I’m holding all goes well.

The product works on battery and without a computer, so the problem of mass or a bad earthing that would interfere is to be excluded, for my part the problem happened to me when using the Prime Go on battery and if it was a problem of humidity or electricity the problem will also be apparent on the left jogwheel, even occasionally.

Totally true. I was just talking about earthing in general as the Prime Go doesn’t have an earth however the touch capacity works by conduction and as the platters are separate it is possible to have just one malfunction under static discharge or damp conditions. Pioneer DJ used to have a separate sensitivity control on the right of the front panel for the left and right deck on the original DDJ-SX (I used to have one).

There could be a hardware fault with the connections from the jog to the chassis but that is just theoretical. Software could be updated to get better measurements from the hands etc (some controllers are so sensitive you just have to hover a few millimetres over the platter to control it!).

The biggest problem with capacitive jogs is conduction. Any mobile phone made within the last 10 years has had a capacitive screen and we don’t have to be earthed to use it but they usually fail if we are wearing gloves or in humid conditions (wet/damp screen). This breaks the resistance so control can’t be made. It is the exact same thing.

By going into vinyl mode you can tell if it is the capacitive jogs as it disables the touch part of the jog wheels and only controls forward and backward movement.

Let’s hope it isn’t hardware.

I did have the error pop up again (it maybe happens around every 1 out of 3 times I use the GO), deactivated vinyl-mode, and it still didn’t work.

So I’m still convinced it’s a software issue. .

2 Likes