[UNDER REVIEW] Deck 2 & 4 not playing tracks correctly

Deck 1 & 3 play without any issues, Deck 2 & 4 have been troublesome from the beginning, tracks slow to load, start and stop play intermittently or not at all. I can press play on either deck with a track loaded, nothing may happen, then all of sudden it starts playing the track on/off, almost like it’s skipping or buffering, then stop completely.

I’ve tried 2 different USB sticks (sandisk 16 & 32gb) which have been used with my pioneer cdj without issues (beatport pro, traktor, rekordbox).
Went through the guides and checked the settings, not finding any issues there.

I can assign and load tracks without issue.

So problem with playback for deck 2 & 4 only. I compare the problem to watching a Youtube video with a slow connection. You can hit play to watch the video, but it gets interrupted along the way while you wait for the video load because your connection isn’t fast enough to keep up.

Any suggestions on what to do?

it’s frustrated me enough that i’m tempted to return it, thinking i have a defective unit. Sorry to be noob, veteran dj here that has worked on many, many pieces of equipment, but never had something come out of the box like this.

1 Like

HI @MPERRY, sorry to hear you are having issues. It sounds like you’ve been thorough in your troubleshooting, so I’d recommend talking to customer support to see what they can do.

https://www.denondj.com/support

Regards J

Hello! I’m having the same issues with my Prime 4. The playback from decks 2 and 4 stops abruptly. Also have issues with scratching using the vinyl mode. I’ve tried everything under the sun to fix this issue including reaching out to customer support but having heard back as of yet. I’m hoping it could be fixed with a firmware update. It would suck if I have to return it.

Did you remove the foil on the jogwheel?

HI @Venaroma, could you please message me direct the email address you used for customer support and I will get on them ASAP for you.

J

1 Like

I did! It was working perfectly at first but now its hit or miss. Sometimes it works sometimes it doesn’t.

Hey Guys,

Sorry to hear of this!

To me, it almost sounds like the platter is being inadvertently triggered which could stop the deck and also sound like distortion (buffering) if the touch actions were rapid enough.

When the deck refuses to play is the platter LED White, like it is being touched?

Does it happen if you move the PRIME 4 to a different room in your house?

scratching is also an issue for me on those channels. unit is completely unwrapped, no film, foil or packaging on it. Jog wheel remains the assigned color, only strange lighting noticed, is when the error is occurring, the green level indicator for that channel will sequence backward (blink one at a time down). I’m not one to be a guinea pig, so i’ve already asked the store for a return/exchange so it can be returned to denon for further testing. If the next unit has an issue, i’ll contact support to make sure it’s not firmware.

Thanks for the additional details and noted that you’re already in process of replacement.

Could you provide the last 4 of the serial and the dealer name so we can follow up with them?

The LED behavior is actually a feature. It’s called “Peak Hold”, which momentarily locks the highest meter value for proper balancing of tracks that may have fast hits which might make it difficult to match levels. Once the audio is stopped, the highest meter will momentarily hold and then slowly drop.

Make sure the electrical socket is properly grounded using a tester. Then if it’s still eventually happening again, try grounding your body to discharge static electricity into something metal on the unit. Touch a rear grounding screw or a USB port briefly.

sn last 4 are 0775, store is guitar center

1 Like

I am having the exact same issue but with Deck 1/3. To test I have been playing on Deck 1 in continuous mode and it will eventually get stuck after some random time. Trying to resume a track on Deck 1 with the play/pause button does not affect the track but the LED will switch from solid to blinking. Sometimes I will press the play/pause button repeatedly and it will start for a moment then stop again. Switching to Deck 3 will work as expected but seems to have the same issue over time. So far have not had the same issue with Deck 2/4.

I opened a support case via email but have not had a response other than “check your junk mail folder for a response” which I did and still am not in touch with support. My case number is 1620040. That is the second time I submitted a ticket. The first time I got nothing. I would call in but this issue isn’t something that is reproducible on command.

Just reproduced the issue on Deck 1 again. The hot cues still allow the track to jump around but doesn’t play. Moving the platter around does produce scratch sounds. While the issue was happening, I loaded the same track to Deck 3 and it started to play but became very choppy as if the track was buffering.

I am also having issues when loading tracks onto the decks sometimes it will load immediately and then it won’t. It appears to get stuck or deciding what to do. I have had the Prime 4 for 3 weeks, I will monitor this hopefully it won’t continue.

Hi @btmlim, it sounds like you may have a hardware issue with your unit. Please send me a PM if you still require support. I’ll do what I can to expedite the process for you. Thanks!

Hi @JWiLL … Appreciate the response. I think you are correct that it is a hardware issue. After further testing, the left deck platter doesn’t actually stop or scratch the track at all, meanwhile the nudge still works. I have noticed some exterior impact damage to the shipping box on the bottom left side which may imply the unit was damaged in transit. I’ve initiated an exchange with Amazon so hopefully that will sort itself out. Glad it isn’t a software issue. Thanks again.

Ahh that is a bummer!

Please let me know if you have any trouble with returning through Amazon and we will take care of you directly.

[Moving to general PRIME 4 area as this is HW and not SW/FW related.]

I had a similar issue last weekend during a gig. Worked perfectly for like 3 hours and then when using deck 3 it just suddenly stopped playing. Could not resume via play/cue button. After I started a new track on another deck I was able to load new track on deck 3 and it worked again. Not very nice behavior during a performance :wink:

Same exact thing happened to me last night!

I had the opposite recently on deck 2.

I couldn’t STOP the deck. I pressed PLAY/PAUSE but the track carried on and if I hit CUE it only set a temporary cue while the track still played.

It sorted itself out after a bit but yeah… it was opposite to not starting… not stopping!