Tidal - No Source Drive Available

After streaming tracks in Tidal, I added various cue points along the way as well as adjusting the beatgrid if necessary (as first beat is sometimes cut off). My SC5000’s work fine while using Tidal as well as tracks on my usb which is input on the front usb port of the player. The problem arises when I want shut down the players. The following message appears;

No Source drive available

Beatgrid, cue, loop and waveform data will not be saved. Played state will not be shown. To enable these features, connect a compatible drive.

As a result, my cues and adjusted beatgrid have not been saved. What am I doing wrong?

Thanks

This might be why your reliability has been high. When it is using a drive, reliability is poor for me with SoundCloud.

Are you suggesting using an external SSD? If so, have you tried it??

My reliability is much better playing off a drive, even a mechanical drive, or doing streaming with no drive compared to using streaming and letting it save stuff to the drive. I’m suggesting that you’ve had good luck with streaming tracks to the Prime playback hardware because your units are malfunctioning and thinking you don’t have a drive connected. When my units have a drive connected, the streaming services stuff seems unreliable, at least with SoundCloud. So fixing just this particular glitch might not actually improve your experience with the current firmware. You’ll be able to save all the meta info, cues, etc, but the actual experience of playing on the decks using streaming might actually degrade. Might be worth looking at this glitch as a glass half full situation with the current two Tidal & SoundCloud enabled firmwares.

Thanks for all the info. I will try using my external SSD and see what happens. On a separate note, Isn’t SoundCloud still in a Beta version? The website states that Tidal is replaced with SoundCloud until it the final update is available. While I’m looking forward to using it, my tendency has been to wait before updating to avoid bugs. How has SoundCloud been to use compared to Tidal?

I never used the Tidal version yet.

Strange that You have issues with Soundcloud when USB is plugged in. I made an hour set with Soundcloud streamed content and having 3 usb occupied with pen-drives. Switching off after this didn’t show any error. Just went off as usually. Next startup the other day - still no problems.

Seems to occur on all five of my units, 3 non-Ms and 2 Ms, with flash drives or big mechanical hard drive or SD cards. Get rid of all the drives and cards and it’s much better for streaming. I do have one M that seems like it needs to be reflashed with the firmware because I pulled a card on it without ejecting first, but other than that and SoundCloud’s annoying EP sample preview things I keep accidentally playing, it works fine this way. I am using WiFi and not hard lines and also have ethernet cable Link connected when in use… not sure if that’s any different than what you’re doing. I also noticed I can’t connect to 5G and rather only the 2G spots work. Perhaps my databases are all too old.

I was running that on wifi via iPhone hot spot on my SC5000M. But I had also connected x1800 and 3 more decks on LAN 2x normal SC5000 and one more M. In this deck were all 3 USB ports occupied and still soundcloud worked ok. No issues. Also reverted back to play from usb without a glitch. Switching off and on - as usual. All 4 decks behave like they should.

Continuing the discussion from Tidal - No Source Drive Available:

Hi Guys,

First time subscriber to this forum

I have just purchased a pair of SC5000’s which I love. I signed up for the 3 month free tidal subscription and seem to have the same message “No source drive available” The only way I can save my changes to tracks in tidal is connecting a USB drive after making changes eg. hot cue, etc which is not ideal. If I have any USB drive connected before accessing tidal none of the changes are saved and the No source drive amiable message appears. Any one had a work around since this original post?

No one in this thread seems to have mentioned the format of their USB drives, or whether they have been run though Engine Prime or not.

Just being logical here and covering all bases. Are your USB drives FAT32/exFAT, and do they contain an Engine Prime database?

It’s a great question. I have tested both Xfat & Fat32 configure with engine prime access to all tracks in the my USB HD. No issues with access to tracks. Since my earlier post I tested a number of scenarios and it seems that the changes are now being captured from tidal tracks but the No Source Drive Availability Error message keeps appearing.

Seems inconsistent but as long as it’s saving the changes that’s the main thing.

BTW, I meant EP vs LP, not Engine Prime.

I don’t if you’ve resolved it mate but I had a similar issue. I realised that you have to select a drive source first - usb or SD before launching Tidal. Once i did that everything saved fine - loops, key, queues. Wound me up that for weeks!

Now if we could add to and edit tidal playlists on the unit I’d be made up

1 Like