Talkover button does nothing

So I’ve had my prime2 for a couple of months now and I finally got a decent microphone for it. Nothing too flashy just an Amazon knock off of a different microphone but when it’s plugged directly into my amp it sounds really decent so I went ahead and plugged it into the microphone combo input jack on the back of the prime unit and started using it in my twitch streams.

Took me a little bit to find the right settings to make myself sound good with the music and without and I’m still kind of working on that part but…

I was under the impression that the talk over button would duck the music 5 or 10 decibels automatically whenever the microphone input would sense enough of my voice…

Mine doesn’t seem to do anything

Like I noticed in the twitch stream that the music was not ducking and that I was having to manually turn the track down to talk over it.

So I started digging around in the settings and messed with a mic attenuation and realize that that was not what I wanted at all and put that back to zero.

But yeah, for the life of me I don’t understand what the talk over button is for if it doesn’t automatically duck the music down when you talk…

Did I get a second defunct unit as a trade-in for my first defunct unit??

Plus my knob that switches my headphones from the master to the cue has a horrible static in it…

But only when I’m turning the knob. Once I stop turning the knob and I’m listening to the master or a blend or the cue, everything sounds normal but as soon as I start turning the knob the headphones fill with a terrible static noise that almost drowns out the music…

Starting to get pretty upset that this is the unit they sent me to replace the one with the broken fader that they sent me after I gave them all that money.

Anyway is anybody else having issues with the talk over button or maybe am I using it wrong? Like do I have to set it up in the settings or preference menu in order to make it work?

Any help would be extremely appreciated…

I don’t have the P2 but is there not a setting for the talkover “gate” level where it cuts in?

I know some other units have this.

Hey @DJ_Lys_2 Maybe this will help understand the “ducking” feature of the talkover button:Denon DJ

If this feature isn’t working, feel free to let me know.

So the article that you linked me to literally tells me to do that thing that I already told you that I’m doing in my original post. Pressing the talk over button in order to duck the music so I don’t have to yell into my mic or manually turn the volume of the track down.

Problem is, when I hit the talk over button it literally changes no volume of anything…

So I go through the utilities and settings menus and I found something called Mic attenuation. When I adjust this setting to negative 10 or -20 it literally just lowers the volume of the microphone through the master channels and not the music that needs to be ducked down so that the microphone can be more clearly heard…

Is there a different setting in the utilities menu that I need to be looking at?

I can’t seem to find documentation through Denon or through YouTube for that matter on the proper way to set up the talk over button to make it actually duck the music and not the microphone…

Hey @DJ_Lys_2
The Talkover should duck the master mix after you’ve engaged it. After reading your previous post have you tried turning up the level of your mic after engaging the talkover? Try keeping the mic attenuation at 0 and increasing the level of the mic to see if that has any effect. If that doesn’t work we’ll take a closer look with a technical support agent.

All turning up the microphone volume does is make me sound more distorted or not once it reaches a certain level… From what I come to understand we’re supposed to keep the microphone volumes to the level where the green light is fairly consistently lit whenever you’re talking… So that’s where my volume level of my microphone is set to…

I’ve tried turning it up and turning it down and all it does is make me get louder or quieter but it doesn’t affect the music at all.

My talk over button lights up and acts like it’s engaging but at no point does the volume of my master mix ever change at all whatsoever…

I’ve already had to send one unit back because of an up fader issue on the left side deck… Really not looking forward to sending another one back because of a broken talk over feature…

Hey @DJ_Lys_2 - You may want to consult with technical support in this case. Perhaps providing them with a video would be helpful as well. Anything to help determine the issue. Try submitting a ticket on our site and let me know how it goes. Would love to know what the issue is as well.