Stuck at update available

  • Software or Firmware Version: (1.4.1)

  • Steps to Reproduce: (Go to device info, firmware update)

  • Expected Result: (It should be up to date “Check for updates” showing on the button)

  • Actual Result: (It shows “Update available” while it is the latest firmware version)

  • Reproducibility: (Every time i turn on the unit)

I have updated both of my SC5000’s but one of them is stuck at “update available” after the update, the other one is fine. I’ll attach photos of both of the SC5000’s.

1 Like

I have the same thing happening today!!!

I’m glad it’s not just me. I even tried to update a second time. Still says update available on player number 1

@DJGK

I fixed it!

(Player 1 was showing update available) Even though both firmwares were 1.4.1

Here’s what I did.

I flashed player 1 down to 1.4.0, then I power cycled the player and flashed it back up to 1.4.1

That fixed it. Both players now say up to date and check for update.

Note: I tried flashing 1.4.1 with 1.4.1 and it did not work.

So something about using a different version and then back up seemed to fix it.

Thanks for the info! I’ve also tried flashing it again with the 1.4.1 but with no luck. I’ll try flashing it with 1.4.0 then with 1.4.1.

1 Like

Please let me know if this worked for you. If it does we need to make sure people know about it because ive read a bunch of people even with past firmware updates that couldn’t figure it out.

This sometimes pops-up and does not always have the same solution.

Did you all update with USB-cable or with USB/SD-drive method?

I used a usb thumb drive with the firmware on it to flash it down and back up again.

Alright.

USB-cable method used to reset more than USB-drive update method. I prefer the drive method also, because all preferences are retained, but sometimes it needs more of a reset and cable method should be used.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.