Sound issues using ASIO driver

Good Morning to the wise!

I have purchased the MCX8000 and first time out last night. I have an issue with the sound. I am using Virtual Dj 2020 on my laptop. The laptop is an i7 with 8Gb ram. The sound will be fine for about 40 seconds then will go all distorted and then go silent. The only way to get the sound back is to close the software and reopen. I think it may be to do with latency but don’t know what these settings should be. Any help would be appreciated.

There isn’t a right setting for latency that covers all laptops. Sometimes the faster the laptop the more ■■■■ they install on it at the factory and the slower it runs DJ software.

Set it to something high like 60ms - if that works for the whole time, even when the laptop gets hot, then try your next gig at 50ms for the whole gig, then a whole gig at 40ms etc

At some point, you’ll get it sounding fine for first hour, then the sound will crap out when the laptop gets hot. At that point just go back up to the last latency that worked for the whole gig

What make is your laptop? Dell and HP are really bad for this but Lenovo are very good in my experience.

I’m running the MCX8000 with VDJ 2020 and the standard ASIO buffer with no problems.

Try a latency monitor to see if it is high then try shutting off devices to find out where the bad driver is.

Its a Dell Inspiron XPS 17. Had the MC6000v2 before this with no issues. Will try the latency monitor program thanks for the help and advice guys. Will also try your method as well Antchi.

I ordered a new XPS 13 2-in-1 and had to return it as the latency was so bad. Seems a very common issue with Dell machines.

I’ve never had good luck with DJ software on a Dell machine. I’ve since switched to a Mac but I have dj friends using Toshiba’s and Lenovo’s that never have a problem.

It’s definitely a thing. New Lenovo which is identical spec to the Dell is perfect where the Dell.was unusable.

So … Turns out that a firmware update was needed on the controller. No issues now. Everything set at standard defaults for the ASIO driver and Ultra Latency enabled. No issues. I’ve had 2 Dell laptops and no issues with any of them. I only have the Virtual DJ software on it and the necessary drivers. Running with processor focusing on application rather than background. Usb power management is turned off and hard drive sleep mode is disabled. Just in case anyone else’s has any issues.

Ahhaaaa that’s just what the laptop makers want you to think :thinking:

Can’t see how that would have solved the issue. All the changes in MCX firmware since day one have been nothing to do with the midi or audio. Never mind, if it works now then great!

1 Like

Hello @dazdisco

I had a similar problem and the solution was simple to connect it to a usb3 port, I know that the mcx8000 uses usb2 but from a certain update of windows 10 my 2 controllers (mcx8000 and the cmd studio4) gave that problem in the usb2 but when connecting them to the usb3 worked perfectly

regards