Solved: Engine doesn't import all my Serato crates

When I click ‘‘Update Serato Library’’, Engine Prime imports all my Serato crates, except 1 (Deep & Dark Rollers).

I’ve also removed this crate from Serato DJ Pro and re-added it again from my source folder to make sure it’s directly linked to my current source folder, but Engine Prime just refuses to import this 1 crate.

Below are 2 images of Engine Prime; one showing an imported crate, and the other showing the crate that keeps being empty after updating my Serato library:

Imported crate

Empty crate

Why is that?

It could be, that some of the files have not supportet frequencyrates or bitrates. I would recomment to convert those crates to 44.1 khz / 320kBit / CBR MP3´s and reimport them than. I had some troubles with my studio files with 48kHz, too.

How would I convert those to 44.1 khz?

You can convert them with a batch audio format converter software, but if your files are already in a compressed audio format, you will loose audio quality. If you want to play those files on a high power - high fidelity audio system the sound quality will suffer greatly, especially in the low end area, where the frequencies supposed to be felt will be lost.

well thats a shame lol, still find it odd that only tracks of that crate are not supported, even though I got them all the same as tracks from other crates :confused:

Try to verify the file names for special characters and you can try assigning a shorter name to your crate.

If you swap the “&” in “Deep & Dark” for an “and” in the folder name, hows that go for you?

You could convert to Wav, AIFF, apple lossless or Flac @ 44.1k

That wouldn’t magically make them wav quality (it would still sound exactly like the source mp3), but it wouldn’t make them any worse.

If I ever do this, I normally stick a note in the comments box saying “sourced from mp3” (or similar), so I know not to convert them again.

1 Like

Do you see the crate ‘‘Deep Dark Rollers’’ in that picture of my post? That crate is also empty, so removing the & didnt’work unfortunately

That rules out non-alphabet chars making it trip over then

yeah, and besides, I have other folders with the & character in them and they were imported perfectly fine

How many crates and sub-crates do you have in your database? Check for database structure limitation.

Okay, everyone, I did create a new source folder with a new name (no non-alphabetic characters) and copied all my tracks into that one, and for some reason it worked now. Still puzzled on why it didn’t work in the first place, but it’s fixed now.

Thanks for your help all!


Maybe if the folder/crate was originally named in Serato, perhaps serato stores the crate name in more than once place in the crate data and renaming it in engine only changes one of the places the & was stored ?

Maybe? It’s a guess based on how other systems have a human visible name and a “data name” elsewhere in the file