Serato Unstable after the new 1.4.1 update on the Prime 4

After update my Prime 4 to 1.4.1 the Prime 4 seems to be taking longer to pick up on Serato and the songs seem to be moving out of sync when mixing with out doing anything .

Serato DJ Pro - version Window 10 Pro

1 Like

I have noticed this. Try bringing your latency settings on serato down a bit! Seemed to help out with mine…its not perfect but I chalked it down to needing a laptop upgrade.

Anyone else also having this issue?

1 Like

Thanks for the update, Ill try it later to see what happens, i doubt its a Laptop issue as it was floorless with release of Serato with the P4 before just with the new 1.4.1 it started giving this issue.

Laptop specs i5 6gen with 8Gb ram running Windows 10 pro

Pretty much the same spec as me bud! I’m still playing with the settings…I’ve got it really low and I usually have it quite high. Just hoping it doesn’t effect the sound quality…not noticed any issues yet just the drifting when mixing.

There is a new serato update out, no harm in trying


1 Like

Will do this after work! I was fully up to date at the weekend unless it’s only just dropped…cheers :ok_hand:

1 Like

it just dropped in the last 24hours or so.

1 Like

Checked release notes but nothing regarding Prime 4 will still give it a go when I’m home!

I check it out in a few minutes will advise is theres any changes/improvents, thanks much appreciated.

I just tried using the Prime 4 v1.4.1 with Serato (latest version). Wow, what a crash-fest! :roll_eyes:

On first run of Serato after installing it froze at 50% trying to load iTunes playlists. Why is it even doing that when I didn’t request it? And seriously, I had two very small playlists in iTunes, and it froze Serato?

So anyway, deleted both playlists in iTunes and tried again. Now Serato gets to 100% reading playlists, and just sits there, apparently frozen. Now what’s it doing?

So I look at the Serato logs and apparently it’s been reading my file tags. Again, I didn’t request that. Why’s it doing stuff I didn’t ask it to? No feedback on the Serato screen to show me what it’s doing.

After I go to make a sandwich, eventually Serato seems to be open, so I get the Prime 4 connected and all seems to be working.

After a few minutes of using Serato via the Prime 4 screen, I look back at the computer and Serato has frozen again. It’s still showing the tracks I loaded earlier. When I start clicking around, the whole Serato GUI disappears from my PC screen. It’s still running on the taskbar, and on the Prime 4, but there’s no interface on the PC.

I can’t see myself risking Serato at a gig. So far so awful. :astonished:

:joy: :joy: :rofl: :grin: :smile: :joy: :rofl:

i bet a 100euros its user error.

I dont use itunes,

i ve got a decently specced Macbook Pro 15, a standard macbook pro 13 and a bare bones XPS 13 (Windows 10)

works a peach with my SC5000M and X1800.

But hey use what works for you.

1 Like

User error? I don’t think so. I’ve been using DJ software since the dawn of MP3s. VDJ has been solid as a rock with the P4 on the same system. Serato? More crashy than a crashy thing on crash day.

I may give it a go on another computer, but I’m not confident.

Virtual DJ is a solid program as well. There are things that only VDJ can do.

I’m used to SDJ and it has never given me any issues.

Why are you even considering Serato DJ when you already have VDJ (Prime support coming soon) and Standalone.

I didn’t say I was considering it. I simply wanted to try it out with the P4 - firstly to see how Serato had used the P4 screen, and secondly as it’s supposed to be the “official” supported DJ software.

Turns out the “unofficial” VDJ (at the moment anyway) works better.

FYI I have various DJ software and hardware just to cover as many bases as possible, should I or someone else wish to use it.

You cant go wrong with that. Cover all bases!

Well it seems to run better on my laptop than my more powerful desktop…

No falling over this time.

I did notice something though. With the laptop, the P4 jogs displayed the Serato branding and the revolving play marker. When I used the desktop, the jogs did nothing - just displayed the Denon “flower” in the centre. Hmmm…

Whats the spec (CPU and OS) of the desktop? I know serato does not play well with AMD CPUs.

No no, Intel all the way for me :sunglasses: It’s an i7 7700K with 16Gb RAM running off a 1Tb SSD.

I tried it again a few minutes ago and it’s behaving itself now. Jogs working, no crashing. :man_shrugging:

1 Like