Serato Library - Prime Import questions

if I reanalyse songs in engine Prime does this affect the saved analysis by Serato and vice versa.

I added my Serato Library but I deactivated Auto analyse option to prevent it as I’m not sure if it will mess up my grids, bpm, keys etc in Serato

does prime read Serato beatgrids and cue points?

Only cue points/loops, not beatgrid data–so you’ll need to analyze them in Prime. Don’t worry, it won’t affect your Serato beatgrids.

I’m still having difficulties getting Serato Cue Points to be transferred.

@Gee_DenonDJ and other esteemed InMusic/Denon staff

My Serato library is on an external HD, I have refreshed my Serato Library in Engine Prime the second time I have done this . Took about an hour to read tags.

Following which i created a couple of crates on my Engine Prime USB drive (Fat32/USB2.0/500gb/WD) and I copied a few files from my Serato Collection to the crates. I did the copying inside Engine Prime.

When I pop the Prime HD into the SC5000 I can’t see any cue points. I can see the crates as copied.

Some people here on the forum say it works whereas folks like myself can’t seem to get the cues.

Where is DJ Boothe btw. Haven’t seen anything from him in a minute.

I haven’t made any progress with getting Serato cues to show when I export tracks from Serato Library to Engine USB.

I have tried different combinations.

  1. used my normal Serato tracks that reside in my 2 Tb external HD no joy

  2. I moved some tracks to my internal laptop drive (MacBook pro with the 500 GB SSD), I analysed those tracks in Serato without my main main library connected. I placed some cue points. Exited Serato, started Engine and refreshed my Serato database in engine. It reflected the new library containing the few songs. I then exported the tracks by adding them to some crates in my Prime external HD. No luck with this too

  3. Even the software engine Prime on the laptop does not see cues made in Serato

  4. I also tried using named cues… no joy

  5. out of curiosity I placed some cues on some tracks in. engine Prime and exported…those ones worked. At least that confirms that engine Prime works.

  6. I also tried FAT32 and exfat formatting my external hard drive, still no joy

Please save me from this ordeal. My library is more than 50k songs deep. Years and years of curating and setting cue point in Serato.

The most frustrating thing is that some people report success with Engine Prime showing their Serato cues whilst I can’t seem to get it to do so.


sir can you please shed light on my predicament.

summary : Serato Cues are not showing up on export in Engine Prime software and USB

What Engine Prime does is import Serato cues if they were dragged into the collection from the Serato Panel. The idea here is that if you’re moving stuff over from your Serato collection, that you would want these to come over. Dragging tracks into Engine Prime directly will not import Serato cues. The problem I believe you’re running into is that the import into Engine prime was done directly and then the Serato integration was triggered after. Since the songs were already in the database, the cue import was not done.

What you should be able to do to get all the serato cues imported is to go to the Serato panel, select all songs (ctrl - a), right click and then select Re-import Track Information. This should pull the Serato cues in. Please let me know if this works

Cheers, A.V.

Serato Panel = In engine?

I didn’t drag files directly into engine from Serato. I got. Serato to show up by just clicking Refresh Serato Library after I launched Engine.

I can uninstall Engine and remove the database and start afresh. it’s still early days.

Will try what you suggest sir.

Just to be clear

Step 1. Open up Engine

Step 2. Refresh Serato Library in Engine

Step 3. Select all files from Step 2 and “re-import track information”

Step 4. Export to USB.

Can I batch analyse before eg after Step 3 or after exporting to USB, and not lose the cue information?

That’s correct, and right after step 3 you can then check by loading a song to deck to see if the cues imported. And yes, you can batch analyze after without losing the cues.

I’m on it. When I clicked on “re-import track information” a notification came up saying “Analysing tracks: Xxxxx remaining”.

Xxxx being number of tracks in my library and its counting down.