Serato Error: Failed to Connect Audio

I have the MCX8000 with not the latest firmware because, the screen version is higher currently than the latest firmware. This is my second MCX8000 as I updated the firmware first on my previous unit and then had quite a few issues, the main one being random and constant screen freezes every time I turned on the MCX8000. Serato worked fine with the previous MCX (until the screen freezes). Now every time I connect my current MCX8000 Serato flashes the main screen, then shows Error: Failed to Connect Audio. I am a little resilient to update the firmware as my previous issue and the fact that the current screen version is higher. Any help would be greatly appreciated!

What computer? Mac or Windows?

Mac (OS Sierra 10.12.6)

But I have solved it, so I want to share my experience: I DO NOT feel comfortable updating the firmware on my MCX8000, as every issue that has seem to surface online and what happened to me, seems to stem from the latest firmware. The firmware that came on the unit from the factory will stay on it. Currently it works totally fine as it sits, the latest firmware has versions lower than what is on the unit as well (Display version).

Engine Version: 0148 Display Version: 8661 (both) MCU Version: 2061

So here is how my set up is working. The problem stemmed from my Macbook Pro, I had Sierra installed and I tried High Sierra, both did not work. I had an old hard drive that had El Capitan on it with Serato DJ 1.9.2, so I tried that. Low and behold it worked! So now I partitioned my current hard drive and put on OSX El Capitan (10.11), with Serato DJ 1.9.3, and that worked as well! I am going to try and install Serato DJ 1.9.10 on OSX and see if that works as well, and then rebuild my library.

Denon, please push for an updated Firmware, I do believe someone said it is in the works, but it has been a year for the MCX8000. I will not update my firmware until a new one is released, I like having a working unit. I know this is easier said than done but I just wanted to share my experience. I really wanted the MCX8000, and I don’t want to exchange it for a DDJ SX2.


I too am getting this error on Mac and refuse to even touch the firmware due to a bad update bricking my last one… however, that one already had issues, where this one works enough to where I won’t chance it. I noticed it only started happening after I tried using 1.9.10. Even downgrading versions, I’m still getting the error (am currently at 1.9.5). I know it’s something macOS-related because it works fine with my Win7 rig, however even after removing all traces of Serato from the MBP, it still gives the error. I’m not going to reformat my work laptop so hopefully there ends up being a fix other than a new install!!!

What version of Mac OSX are you running? I found that the firmware that you and I are using, both of us are NOT upgrading it, it can only work on Mac OSX El Capitan (10.11.XX). And I haven’t been having any issues (knock on wood!). I partitioned my MBP and installed El Capitan on that partion, just for Serato and such. Hope that helps!

Thanks for that… I’m currently running regular Sierra. Not looking to blow away that partition but maybe I’ll set up a new partition expressly for El Capitan / Serato purposes.

That’s exactly what I did too, 1TB drive, made a 200GB partition just for El Capitan and Serato.