Serato DJ will not connect to Denon MCX8000

I cannot connect my MCX8000 to Serato DJ - it will not recognize. I’ve tried various troubleshooting options and nothing seems to work.

I read the Serato forum, and there still seems to not be a viable solution. I’m hoping I may be missing something.

Mac or Windows? Which OS are you using?

I’m using mac.

Does your mac detect the controlled without starting Serato ? Check if you have the option to play your system sounds through the 8000. This step is just way to ascertain that the 8000 sound card USB works.

If thats ok then trt starting Serato after connecting and powering on the 8000

Also try to delete old midi configurations in your mac midi utility

I too am experiencing this, on macOS Sierra, only after upgrading Serato to 1.9.10. Downgrading SDJ versions has not remedied the matter. I’ve removed all MIDI profiles and any trace of Serato I could find, yet am still receiving the Error: Failed To Connect Audio! error when launching SDJ. The frustrating part is there is a brief second where the controller is recognized (I see four decks) and then boom, error.

The even more frustrating part is that this is not an issue with SDJ 1.9.10 on Windows 7, which works splendidly. Isn’t it Macs that are supposed to work without asking questions??

1 Like

That is now a myth “Macs working without issues”

I only just downgraded to Sierra from High Sierra. I noticed my ExFat drive was extra slow on HS.

Best to reach out the Serato Support when they are back from holidays.

Have you tried a PRAM reset on your Mac…I don’t know if that will help.

On Sierra, my MCX8000 works with both 1.9.6 and the 1.9.10 (just upgraded). Now upgrading to High Sierra. See what happens.

Just finished the High Sierra upgrade. Started Serato (1.9.10) and it shows my mcx as connected.

All works as expected. So we know it CAN work.

Mind you, this was my order of change:

  1. upgrade Serato to latest version
  2. upgrade Sierra to High Sierra

Not sure what would happen if you turn things around.

For me, the “myth” holds :stuck_out_tongue:

It’s such a common issue with SeratoDJ and EVERY SDJ certified device that they even have two (mac and win) support articles with instructions.

From your post it’s not clear that you have read & followed the instructions contained in them?

For the record, after upgrading to 1.9.10 Serato (on Mac), I receive this error — even after downgrading to an older SDJ version (1.9.x). I’ve followed all the directives as far as removing and readding MIDI devices goes, and still no dice. Am toying with the idea of upgrading but would rather not go to High Sierra for work-related reasons. Why doesn’t this work with Sierra? 1.9.10 works fine on my Win 7 Pro box.