SC5000M Pitch slider freezing & firmware update issue

So ive just started testing my unit and all seemed ok and then I noticed at times when I didnt have Master or Sync engaged the pitch slider just wouldnt work. See video you will notice im moving it up and down above zero and it doesnt change the tempo at all…until I take it below zero. view video here In addition to this Im unable to do the latest firmware update on the unit and despite emailing denon support several days ago Im still waiting to hear back.Im hoping that the update will sort out this bug. When I insert an exfat flash drive with the update root file and select reboot under firmware, the unit is supposed to recognised the new firmware on the flash but instead just says rebooting in update mode and then i get a start up graphic with a small arrow facing down and thats it it freezes indefinately.

Hi 2Darc,

That is NOT a bug but normal operation! You use two layers and the fader needs to catch-up on the fader position it was before. Hence the green triangle showing you where to go with the fader.

Edit to clarify with an example:

On layer A you play a track at -6%. You switch to layer B and change the fader to, let’s say, +4% position because of the mix or whatever. If you then go back to layer A, the position of the fader would not be -6% anymore, so the SC will indicate to you (with the green triangle led) to move the fader to where it was. When it’s at that previous -6% position, the fader has caught-up and starts working again.

This catch-up is also active when you change the pitch range of a playing track.

You seem to have 1.2.x.? Could you perhaps show us the filename that’s on the flash drive you’re trying to update with?

Also remove the blue USB3 cable if connected to a computer while updating with a flash drive or else it’s waiting for input from the computer update procedure.

Don’t know for sure if the flash drive needs to be FAT32 for the purpose of updating that way. Mine is.

Hi Reece thanks for your reply. Just to clarify as I think you may of taen my comments out of context… In the video you will see that I was playing C&C and had mixed out of another track on the other layer (without master or sync selected), C & C was playing fine for some time… I was then attempting to increase the Tempo on the C& C track as i knew the track i would be mixing in next on the other layer was a bit quicker (this is prior to cueing it up). When attempting to speed up C&C the SC wouldn’t allow me any control over the slider until i had taken the fader below zero. So imagine if I’m playing a party with the one SC unit and i need to speed up the track thats playing to the crowd but first have to slow it down until the slider allows me to control the tempo…I would clearly hear a disgruntled crowd. This is def some sort of bug also an intermittent problem.

If this was some sort of pitch lock function that could be disabled then fine if this behaviour isn’t fixable on the firmware update then I will probably have to return the unit as unfit for purpose.

Please, read my comments carefully!!

Yes, the fader needs to go to the point of where it was before. Otherwise, if you change to the other layer, the pitch would change immediately to the value you might have changed it to at the other layer.

Sorry if I cannot make it more clear. It’s not a bug; it’s a fail safe for us DJ’s!

I’ll try to make a video that explains what will happen if it would not do what it does now.


How people still don’t know about soft takeover after 10+ years of it being a standard feature on all 4 deck controllers/dj software…

2Darc, please read again Reese’s post with understanding and try mixing again.

A question/test in the meantime:

  • Play a track at pitch range setting +/-8% and set pitch to +2%.

  • Change the pitch range while playing to +/-20%.

  • What do you think would or should happen?

  • What does the SC do in this case?

Hi Reese thanks for your assistance, so just reading up on soft takeover… I’m coming from 1210’s so this function is new to me , I guess I was expecting the pitch slider to work exactly as a 1210 without lag or soft takeover. I have tried your suggestions and replicated the issue. Ive noted the green arrow and guess it’s a case of getting used to using +/- to regain pitch control. Regarding the update, yes my current OS is 1.2, according to what I’ve read ExFat formatted should work fine, Ive also tried it with an SD but the root file Isn’t detected in both instances. I’ve just tried in usb slots at rear as well as front and get same results. I’ve also used a freshly formatted fat32 drive with the update root file and still only getting the option to reboot in update mode rather than file detected.

1 Like


If you’re used to SL’s, then just stick to one layer and two players. Expand this later to double layering. :sunglasses: Pitching smooth as butter!

As for the file, please post a screenshot showing the file name that’s on the drive. Just for me to check.

1 Like

For database and music, yes no problem, but for updating I doubt if it is has to be FAT32.

Also, in the beginning I had problems with hand-out flash drives and simply changed to an older SanDisk 32GB that I had laying around; just for updating, flawless.

Thanks for your explanation Reese much appreciated, I’m brain dead today but the penny finally dropped lol. Best solution as you say is for me is get another unit.

Re. Firmware update Here is a pic of the file on the flash key.

I’ve also tried with the SC5000MPrime1.3.1Updater-Win.exe file.

YES definitely buy a second unit. So much joy.

I was also used to SL’s and Denon cd-players. Changed to Traktor D2’s to do some simple bedroom mixing. Missed the manual pitch too much, so went all out for the complete Prime set.

Thanks for the screenshot. I’ll try to post one also.

1 Like

You may need to rename the image file when you stick it on a flash drive. You want no spaces or underscores, but hyphens are ok. I believe InMusic also has a download that has already been properly named for you as SC5000M-1.3.1-Update.img. You want the download that doesn’t have all the other stuff on it. If you get the big download for using it over a USB cable from a computer, you need to rename that image.img file.

As for soft takeover, while it still has some minor issues (like the light momentarily coming on for some reason), it’s mostly working fine right now. It was previously very glitchy and annoying. If you load a new track, it sees the fader position immediately. If you change layers while a track is still playing and want to change this layer’s pitch fader, you first need to move the fader to the position for that layer’s on-screen pitch from before you went to the other layer. This is normal and desirable. There is no reason for soft takeover to be disabled as a Utility/Preferences setting. The only time you will never get soft takeover is if you disable the Layer function, which you can do with shift+layer.

FYI: If you hit cue or pause to stop the platter on the M, right now you need to either wait for it to stop completely on its own after the slight wobbling or you need to manually stop it fully yourself before it will start seeing the platter motion again. I have a feature request to resolve this, but I’m pointing this out to you just in case it is confusing when you encounter it.

Let us know how it goes.

1 Like

Reti beat me to it (posting on my phone so). Spaces are indeed to be left out and a correct file is downloadable from the site.

Download the zip file from the link above and extract the SC5000M-1.3.1-Update.img file and put this on a drive.

Nice one guys, thanks for the helpful advice. All sorted, updated via usb cable & laptop. Enjoy your weekend.