Reverb FREEZE mode

Hi folks

Just purchased the x1800 and now I have the complete prime set.

Beeing a noob again getting used to the mixer I have a question I would like to ask : How can one disable Freeze on reverb. I would like to have a tail rather than Freeze.

Thx

you push one of the rotary knobs in to freeze. I can’t recall which one but if you don’t figure it out, post back and I will tell you when I get home.

It’s one of these two…

Thx for reply but it’s not that one. You can change the intensity of the effect but Freeze is not manipulated by neither of those rotary knobs.

It is the FX TIME knob. Here is a video (if you can’t view it, right-click and open in new tab):

Maybe I’ve misunderstood you’re question but either way, that’s all you can do to it (besides changing the depth) I think.

Yes you are right. The FX Time knob turns on/off FREEZE function when BPM FX button is active. But is still not what I was looking for.

I’m just used to use reverb the Pioneer DJM way. That "tail"left behind by the reverb was part of my workflow doing a lot of transtitions this way.

Oh well, I will use the wash out sweep fx instead for transitions.

Thx for taking the time to record video and explain. Cheers mate.

1 Like

Do you mean when you press the on/off button? I.e. using the reverb during a transition, complete the mix (drop fader) and hit off, but a tail of the reverb will still continue to fade so the mix doesn’t cut abruptly? If that’s what you are asking for, I’d like that too, if not, then I’d like it anyway!!

Think I might have seen a request for something similar on here before.

Yes I know that when I drop the fader the music stops but the reverb tail continues…That s great.

Let me explain exactly what I mean. Sometimes I like to build up using reverb. I like to use reverb before the drop to make it sound more killer. Problem with x1800 is that when you turn off fx button when using reverb and the fader is still up the effect dies instantly. On the other hand on a djm mixer when you build up with reverb you have that “tail” right after you turn off beat fx button.

That s about it. Hope you get what ai mean here.

1 Like

I do, similar to what I meant, it’s a good while since I’ve used any DJMs, I actively avoid them if I can now!!

Tails definitely needed on all FX, and user definable too.

Put it in for a feature request if it’s not there. I would vote for it too.

1 Like

It is simple, don’t switch the fx off, just drop the fader down, the tail will remain. Then after tail is gone switch fx off. Simple.

1 Like