[RESOLVED] Unable to update Prime 4 Firmware

Still cant get my beta update on :frowning: been at it a few hours now. got the download on laptop and usb connected to prime 4 every way i know, gone into utility clicked update firmware and nothing happening at all, just hanging can anyone please help ? i have the tidal account active

Hi @holly260426,

Sorry to hear of the difficulties.

What does the Updater app say when you click UPDATE PRIME 4?

Few things to check:

  • Have you rebooted into update mode from Utility on the device (At the bottom press on the word “Reboot”)?
  • Is Prime4 in update mode (logo with a microchip on screen) waiting for the computer data?
1 Like

Well the only issue or difference i have noticed is that the extraction of the update opens on my pc and asks for the P4 but it does not do this on my laptop which is the machine that next to and connects to my p4 :frowning: strange. I have the update 1.4.0 on a usb stick plugged into p4 and on my laptop with the blue cable plugged in. when i press update reboot it just goes through the process without actually doing the update, i have left it nearly 30 mins now and nothing happening ??? I am doing something wrong ???

Yes but nothing happening apart from it going through the motions, so its not picking anything up :frowning:

What is the correct process please ? download update put on usb/computer attach to prime 4 and reboot/update via utility ??? the last update went perfectly fine .

Hey folks,

I’ve moved this into its own topic so we can better track it.

Holly - Can you take a screenshot of the updater or describe the state that it’s in? We need more information before we can help troubleshoot what’s going on.

Thanks,

Vince

Please turn off AntiVirus during the update. Sometimes this can block the update process. I had the same issue at my first install of the beta firmware. Without Antivirus it goes through it without problems. Also I had the Issue where the Screen was frozen at Bootlogo of 1.4. I had to hardreset the device … after that - it works.

Turned anti virus off still no joy. my pc will open the update and extract but my laptop wont :frowning: my pc is in another room laptop next to the P4 disabled firewall and antivirus starts to extract then nothing …

Holly,

Please be a bit more clear on exactly what is happening. We won’t be able to help you troubleshoot otherwise.

Please describe what is happening and the steps you are taking. Here is an example of what I mean:

  1. I downloaded, unzipped and launched the updater on my computer. The applications shows a green button called “Update Prime”
  2. I went into utility mode and pressed Reset at the bottom of the screen. This showed a “Reboot into firmware update mode?” dialog which I then pressed “Yes” on.
  3. The unit reset into firmware update mode and shows “Prime 4” on screen along with a microchip with a small arrow pointing down at the bottom of the screen
  4. I then connected the USB cable to my Prime 4 and my computer
  5. I pressed the Update Prime button on the FW updater. This showed a progress bar with “Updating Firmware”
  6. When this finished the Prime 4 reset and then booted into the 1.4 version of firmware.

Please be detailed. If we don’t know what is going wrong, all the solutions put forth will be stabs in the dark and probably not helpful.

You say your PC is in another room. Does this mean you have tried connecting the Prime 4 to the PC and also didn’t work?

step 1 downloaded the update Prime41.4.0bUpdaterWin this is in my downloads folder and i made a copy to usb.

step 2 as a test i opened the file on my pc all was ok it asked for the prime 4 to connect.

step 3 i tried the same on my laptop but the application will not open, it extracts to 100% then nothing happens.

Therefore i cannot go any further, if the application opened on my laptop i could then use the blue cable to connect to my laptop update firmware reboot on the P4 and all would be fine. The last update worked perfect and first time, so i do not know why i am having so much trouble this time ??? Hope that is a more clear description of what is happening as i cannot add anything more ??

I do understand that a laptop is easy to connect since it is mobile. But since your pc is working (as far as I understand you), can you try to put the P4 next to your pc than? This sounds like a problem with your laptop (os/driver/software/hardware), not the file itself.

Holly,

Please answer this question.

Please run through the firmware update process again. After every action, write down what you did and describe what happens on both the Prime 4 screen and your computer screen.

This needs to be complete and detailed. If it helps, pretend you are sending instructions to your grandmother who must also update her Prime 4 to the latest beta firmware. She’s not so good with technology, so every step must be documented, along with everything that happens, so she knows she did the right thing. You are going to snail-mail these instructions to her, so they must be perfect (she doesn’t have email). Make it that detailed.

Only then can people actually figure out what’s going wrong with your system.

If that sounds like too much trouble, you can contact customer support by phone and they should be able to help: https://www.denondj.com/support

You can also try that: Right Click the Updater and choose “Run as Administrator” - so your Laptop has more rights. If that also doesnt work - I don´t have more clues on how it hangs :frowning:

Another shot in the dark. Try another USB port on the laptop.

1 Like

So ive fixed it and im now updated, very annoying, spent 4 hours trying to sort it and now done in minutes. Bascially my laptop will NOT open the update Prime exe file, it opens all the other ones. My pc will ,so i have had to disconnect all cables from my P4 clear my desk to be able to plug my P4 into my PC and it updated instantly. Not the way i wanted to do things hence why i got a laptop to make things closer and easier but at least its resolved zzzzzzzzzz.

2 Likes

I don’t want to be rude, but we do deal with pretty advanced tech here. And I’m not just talking about the P4 :wink:

Your PC is complex on it’s own. Don’t blame Denon. And what a modern problem to strugle with cables…

Just curious: What OS was the laptop?

And about the 4 hours, you stated 12 hours ago that the pc simply worked…why not immediately test that then? Disconnecting one power cable and some RCA’s.

The fact that it opened on your PC and not on your laptop should steer you towards a preliminary conclusion that something is different about your laptop and not that something is faulty with the upgrade process.

And while big, it’s still a controller. Not sure how many cables you have attached, but if you are a mobile DJ you would be plugging everything in and out every gig you play out :-D.

At the end of the day you got it working and can now enjoy the industry-first wifi-integrated full streaming integration. And (again) if you are/were a mobile DJ, this is truly the solution to solve carrying around 500GB of tracks (even if on an SSD disk) and managing your request collection.

The fact that the Prime 4 has a serious computer on-board that allows lots of new stuff to be added in the coming years through firmware also means it will stay current a lot longer than a lot of “standard” controllers.

Who blamed Denon ??? think your a little defensive ?? Denon is outstanding and so is the P4, its the best thing ive seen or used, i just wanted a solution and felt a little miffed as to why the last update went perfect yet this one didnt? i never portioned any blame to anyone, ive spent thousands on Denon equipment if i had issues with Denon I wouldnt give them my money.

2 Likes