[RESOLVED] Special characters causing problems

  • Software or Firmware Version: (1.2, 1.3.1, etc…)

1.3.1 SC5000M

I haven’t checked the non-Ms yet for this.

  • Steps to Reproduce: (Turn on unit, press button X, etc…)

Try to load a track with ą ę ś ć ż, ö, etc.

  • Expected Result: (ex: It does X…)

I expect it to load the track.

  • Actual Result: (ex: It does Y…)

It won’t load certain tracks of mine with special characters, like an ö. If I change it to Royksopp without it, the track loads.

  • Reproducibility: (ex: Happens 1 out of 10 times.)

Happens every time with the Röyksopp track.

  • Other Relevant Configuration Info: (ex: Plugged into a Windows 10 laptop.)
  • Operating System & Version (if applicable):


  • Link to Video Repro:

VID_20190626_162841.mp4 (2.0 MB)

Hey @Reticuli,

Thank you for the detailed report.

So far I have not been able to reproduce in my environment. I was able to load the files below to SC5000 v1.3.1, SC5000M v1.3.1, and PRIME 4 v1.3.2 without any issue. I loaded them via Folder system without running them through Engine Prime just like you demonstrate in your video.


It must be more than just the special character causing the behavior. Could you provide 2-3 tracks that this happens with?


Perhaps this has something to do with the limits of allowable characters in the used file system

So far, I have not been able to reproduce in my environment. The files provided with special character play as expected.

Have you tried to rename another track that plays with the name of the one that doesn’t? It would tell you if it is the file name or not. You can go through the whole metadata to pin point the issue. Just a thought…

This may relate to how the dipthongs and diacritics (or whatever the dingly dangly things are called) are encoded. I vaguely recall that some letter and their modifiers can be done as two separate characters which the unicode standard then combines into one.

But yea in order for us to figure this out we would have to get hands on to figure out what’s going on.

JWill and I suspect it was just a corrupt file. In addition to the original, the drive appeared to have a 0mb version also showing up, and I think that was the only one the players could see.

There was some other weird, stuff, though, with %28 and %29 showing up instead of ( ), and it also seemed like removing the special character fixed it, but that could have been as simple as effectively resaving the file and/or doing something to the flash drive’s file table system.