Record to USB drive file errors

Does anyone experience file errors when recording to USB drives?

Numerous times I finish recording, successfully save the file, then when I try to load it into a deck or play on laptop, etc, it says there is an error with the file. Using a 32GB SanDisk Ultra fit formatted exFAT.

Now I’m just a bedroom DJ so mixes not recording is just inconvenient and annoying, however I can imagine for any pros this could be a serious problem.

I’m going to see if the same happens using a SD card…but I shouldn’t have to :rage:

Does the ultra fit mean anything that the usb stick does special? Like encrypting recordings or file saves ?

No. Regular USB flash drive…just small physically.

That small might mean they’ve comprised on the chip sizes inside and therefore speeds.

Counterfeit/slow SD card?

How would that affect recording to a USB flash drive?

Probably due to hardware design/limitations recording may be direct write without buffering. Slow write speed may result in data loss/corruption.

A slow SD card will affect recording to a USB flash drive?

Sorry, USB drive :laughing:

‘…hardware design/limitations…’ - This meant to be a ‘Pro’ device!

Go is not a “PRO” level device. SC6000/X1850 is “PRO” level. Not a single standalone unit with recording capability will buffer record output before writing to media - You’ll need a good amount of internal memory to buffer a 2h wav record file before writing. Remember that you simultaneously write and read from the same stick - A slow/bad stick may not be fast enough. Of course, due to copyright issues, you can’t record from streaming sources.

1 Like

Anyone who does not understand that simple fact is definitely not a PRO dj based on his lack of knowledge about the DJ gear they are using. I’ve seen all kind of arguments including “then why is it labeled as “Prime” Go?” :joy::joy::joy:

you cannot expect the same features/hardware that are on a 3000€$ setup to be present on the 1400€$ (I’m looking at you Prime 4 owners!)or 1000€$ one.

1 Like

I simply wondered if anyone else has experienced the same issue.

have you tested a different USB drive to compare?

I tried a different drive last night and it worked okay. It was a newer USB 3.1 drive, the problematic one is 3.0. Maybe this makes a difference. I’ll keep trying with the new drive and see. It was always an intermittent issue, but happening more often than not.

1 Like

Cool! Internal stick memory speed is more important than USB interface speed/type (2.0 / 3.0 / 3.1). On my SC5000’s some high quality USB 2.0 Sticks run faster/smoother than ‘bad rep’ 3.1 sticks. Adata UV128 128Gb stick is blazing fast, but Kingston DT50 128Gb is a piece of ■■■■. Both are 3.1 USB’s. A Sata SSD on a 2.0 USB Caddy works perfectly, so USB transfer speed isnt the bottleneck - Storage memory speed is.


This is why there are €30 32gb usb drives and why there are €80 32gb usb drives It’s the internal sustain speed that’s the mattering speed.

1 Like