Problem with firmware update on windows10

Hi.

Im using windows 10 and it struggle with detecting my x1850 mixer in firmware update software. My computer does however detect the usb and recognize the player. I tried restart, reinstall software, etc. Nothing works. Luckily I had a Mac and it got detected instantly. Thought it might be a bug and good to report in. Not quite sure if this is the best place tho.

Regards, stAMy

Had the same issue - so had to use my Mac. But I can confirm its not just you.

It seems to be related to which motherboard USB chipset is used.

Cannot specify which works better, but trying another port might help. Some motherboards use different brands to get more ports on the board; say 4 NEC/Renesas and 4 Intel.

Apple is known to limit its USB port count and mostly used Intel USB/Thunderbolt until late. Don’t know about the new M.

It’s a shame that, for the sake of 3 or 4 firmware updates a year, Tidal wouldn’t host the firmware, then we could just download the new firmware from tidal, straight into the machine.

But i would guess that a download from streaming sites probably gets held in some part of memory that can’t be accessed by the firmware loader , in the online side of some divide instead of the offline side or something

I tried 3 differnt usb ports. No one worked.

True, but it might all be non-Intel, which usually works best. USB is a tricky port type.

Then again, Windows10 can be the problem as well. I have an AMD X570 motherboard. Reinstalled Windows after a year to get a fresh OS again. Even while the hardware didn’t change, USB works better. I just updated a LayYa with no issues (@Wyley1 :wink: ). The previous Windows10 on the same hardware didn’t operate the USB very well…

1 Like

I have a same problem Windows 8.1. Not detecting, tried 3 usb ports. Any help?