Prime 4 Update 1.4 Problems

Hi All, I have just updated my prime 4 to 1.4, it seemed to run through the update mode. Prime 4 connected via USB to an IMAC. I then noticed an error screen on the Mac, I tried to update again same error screen. I then disconnected the USB and powereded down the prime 4. Once I turned the prime 4 back on it is stuck on the Update screen with the Micro chip/download image. I tried re-installing update 1.32 with no joy. How do I get the prime 4 off this update screen?

Thanks all

Hi @Boyceduke,

Try to download Firmware update (USB Updater) if you are having problems with the connection to your Mac.

Instructions here:

Download USB firmware here:

Hi @Boyceduke - It sounds like the device may be stuck in update mode. Do you have access to another computer you can try to send the update from?

If not, please reach out to our support team to resolve this issue.

@addie Good thought! Unfortunately, the media device update mode will not work if the device is looking for a computer to update.

Got exactly the same problem here!!! My screen is stuck on update mode! And the update won’t work… I can’t use my Prime 4 anylonger! Please help!!!

Update Error There was an error updating your device

Finally worked after numerous attempts ;/ Actually just restarted my computer and it worked fine. :man_facepalming: