Prime 4 not responding

Hi Guys,

So I’m having some MAJOR issues with my prime 4. over time I’ve noticed things starting to not respond as quick as it use to be, such as tracks loading and unable to disconnect my USB sticks to eject them. I’ve turned on my unit today and have recieved this error message about the mixer peripherals. if any admin or anyone who has had this issue help me resolve it would be greatly appreciated.

Ive got a video of what’s going on below.

What firmware you using? That happen to me one time which came out of no where. You should update again. Try doing it with the laptop directly

ive got the 1.4.1 firmware on the unit and I have done it direct from laptop mate. Its so strange as I havnt had any issues with it at all until the last few days.

Another thing to that I found on mines when I had the issues. Something with my usb stick. Not sure if one of the track was messed up or something. I know EP haven’t been good. But try a different usb stick. Are u using the beta EP. if not give it a shot an see if u get that issue.

ive just downloaded the beta engine prime and run a sync on new USB sticks. Re - uploaded the 1.4.1 firmware to the unit and I’m still having the same issues. and still receiving the error message about peripherals! :sob:

Wow that’s so strange sorry that didn’t work. Try reaching out to denon they might give u better assistance with your issues

One more thing did u try to do the firmware again on the prime 4. U never know

Oh quick question what formatted is your usb drive?

yes I did , I did a fresh firmware upload before plugging in my USB 's and they are formatted to FAT32 mate.

Is it also formatted also to master boot record?

I know when it’s not formatted to fat32 master boot record. Some unit act up. Not sure if that will work

Might be a long shot but maybe downgrade to the first firmware, try that, then update? Looks like the firmware has caused an issue with the mixer, that’s why its asking to update FW. I think maybe one of the Denon guys should know why its asking this?

1 Like

Really appreciate the help ive had ! ive tried re - installing the firmware updates from the first one to no prevail :worried: I have messaged an admin on here and sent a formal email to Denon about it. Hope I can get it sorted soon! Love my P4 !

Hi @djskizz86 - Sorry to hear of the troubles.

Do you currently have a HDD installed in your PRIME 4?

If you remove the HDD does the problem persist?

Thanks for getting back to me J. No I havnt got a HDD inserted on my unit ! I’ve just used USB sticks.

No problem!

Ok have you tried to update with v1.4.1 again via computer? I’m wondering if the update didn’t fully load.

If you’ve already tried this to no avail, please send me a PM with your contact info and I’ll have someone reach out.

Confirmed this is a hardware issue in PM and have forwarded the info to the local support team.

We apologize for the inconvenience but promise to get this sorted as quickly as possible.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.